Question Using any router decreses Upload speed on my pc!!!

radicle_

Prominent
Oct 23, 2020
29
2
535
0
i tried several routers to connect them to my pc (with cat6 lan cabel)
the upload speed always falls so i get lot of drop frames in OBS
and when i bypass them the upload speed goes up!!
no problem 0 dropped frames

here r the routers i used
ib-wrb333n
tp link archer c20
and 1 more
using router always decreses my Upload speed
and bypassing them (directly connecting pc to modem) increases my upload speed
PLZZZZZZZZZ SEND HELPPP
my frnd has a different ISP and he also is facing the same issue
he is also not able to stream using a router
but by bypassing the router he is able to stream with no issues !!!!
 

gggplaya

Distinguished
What bitrate are you streaming at? Do you really need to stream as high as you do?

If you use Quicksync or Shadowplay to stream, you're using GPU encoding which looks aweful. So people tend to stream at higher bitrates to compensate for the poor blocky quality of GPU encoding.

Nearly all pro streamers use a separate PC to CPU encode their stream, which makes the output significantly cleaner at lower bitrates.

For your routers, try turning off ipv6 if it's enabled, and turn off QOS. The user manual shows you how to disable it: https://www.tp-link.com/us/user-guides/Archer-C20_V5/chapter-4-configure-the-router-as-a-standard-wireless-router#ug-sub-title-16

Make sure bandwidth control is disabled on the router.
 

radicle_

Prominent
Oct 23, 2020
29
2
535
0
What bitrate are you streaming at? Do you really need to stream as high as you do?

If you use Quicksync or Shadowplay to stream, you're using GPU encoding which looks aweful. So people tend to stream at higher bitrates to compensate for the poor blocky quality of GPU encoding.

Nearly all pro streamers use a separate PC to CPU encode their stream, which makes the output significantly cleaner at lower bitrates.

For your routers, try turning off ipv6 if it's enabled, and turn off QOS. The user manual shows you how to disable it: https://www.tp-link.com/us/user-guides/Archer-C20_V5/chapter-4-configure-the-router-as-a-standard-wireless-router#ug-sub-title-16

Make sure bandwidth control is disabled on the router.
is sus tha it is happening due to windows 10
 

sodade21

Distinguished
Apr 20, 2011
8
0
18,510
0
did you found out a solution?
and the problem was always cause when a router was connected to your pc? have you tried via wifi adapter? it was ok?
 
Last edited:

ASK THE COMMUNITY