Question VGA light lit on b450 Tomahawk following RAM upgrade ?

Mori Winter

Honorable
Nov 24, 2015
7
0
10,510
0
Decided to update my PC with some more RAM. Purchased the same model as what's currently in there and went from 2 sticks of 8Gb to 4. Updated BIOS along the way as would originally read 32Gb but only use 16Gb. PC worked fine for a couple of days, then refused to boot one morning.
Solid VGA light on the EZDebug panel. No POST, or image to either of my monitors. No difference if GPU plugged into the lower PCIE slot . Checked and changed power cables. Removed CMOS battery and linked jumpers. Removed and checked RAM in each solt seperately and together. Nada.
Assumed GPU had bricked, unable to test in another PC so ordered a replacement. Same issue with the new card. Now assuming possibly the motherboard is gone, but would love any other suggestions before I start buying more parts. Specs as below, thanks for any advice.

MSI b450 Tomahawk
Ryzen 5 2600x
Original GPU MSI RTX 2070 Super
New GPU Gigabyte 3060
Corsair Vengance LPX RAM DDR4 4 x 8Gb sticks.
Corsair RM750X PSU
 

Mori Winter

Honorable
Nov 24, 2015
7
0
10,510
0
Thanks for the quick response. I'll grab the BIOS files and give that a shot in the morning, my brain is too frazzled and ill probably need to borrow a computer at work for the download. The power supply is just over 2 years old.
 

Mori Winter

Honorable
Nov 24, 2015
7
0
10,510
0
Just as a precaution, I've been looking for motherboards and the original model I have is a little tricky to get hold of quickly. Do you have any recommendations for a replacement that my parts will drop into? Not fussed on manufacturer as long as it will work with my existing CPU and RAM. Thanks in advance
 

ASK THE COMMUNITY