[SOLVED] Visual C++ 2015 setup fail

ishaankaushik

Prominent
Sep 7, 2017
133
2
595
1
I have windows 10 version 1809 and I am trying to install visual C++ 2015. The installer says that the setup failed due to error 0x80070666. It says that their is a newer version installed. I tried uninstalling visual c++ 2017 and then reinstalling it after I installed vc++ 2015 but visual c++ 2017 just overwrites the vc++ 2015 installation and I cannot see vc++ 2015 in the programs list. I can only see vc++ 2017. I am trying to install the latest versions. Should I leave it like that? Also my windows is up to date.
 

Mandark

Distinguished
Sep 13, 2002
1,829
193
19,990
16
you are talking about the redistributable then. in that case if a new one is installed then you don't need the old one. if it fails because a newer 2015 vc_redist is already installed, don't worry about it.
 

ishaankaushik

Prominent
Sep 7, 2017
133
2
595
1
you are talking about the redistributable then. in that case if a new one is installed then you don't need the old one. if it fails because a newer 2015 vc_redist is already installed, don't worry about it.
So should I uninstall all of the previous redistributables and keep the new ones only?
 

Mandark

Distinguished
Sep 13, 2002
1,829
193
19,990
16
no... just keep them all. some apps may still use the old stuff. don't want to break things is my way..... but if you really want to, you can. They may complain and say you may break stuff--which is always possible.
 

ishaankaushik

Prominent
Sep 7, 2017
133
2
595
1
no... just keep them all. some apps may still use the old stuff. don't want to break things is my way..... but if you really want to, you can. They may complain and say you may break stuff--which is always possible.
I had some errors installing the AMD drivers and that is why I wanted to install the 2015 version.
 

ishaankaushik

Prominent
Sep 7, 2017
133
2
595
1
at this point, if I were you and had my data backed up, I would do a full clean install of windows 10, then install your drivers
Already done that several times. The error is not shown by the AMD installer but by device manager and events viewer. It is error 0xC00000E5 that I get. Wasted my card's warranty for that. Still I get the error.
 

Mandark

Distinguished
Sep 13, 2002
1,829
193
19,990
16
installers usually put a log file in the user temp area,
you can get to temp by doing the following

  • open windows explorer
  • in the address bar at the top type in %temp% and hit the Enter key
go there and look for *.log and *.txt files and anything with AMD titles. look at those files with Notepad or any good editor. they will have the errors logged usually
 

ishaankaushik

Prominent
Sep 7, 2017
133
2
595
1
installers usually put a log file in the user temp area,
you can get to temp by doing the following

  • open windows explorer
  • in the address bar at the top type in %temp% and hit the Enter key
go there and look for *.log and *.txt files and anything with AMD titles. look at those files with Notepad or any good editor. they will have the errors logged usually
Yes the AMD installer has generated a log file but I am not able not to understand a thing. It says there is some error with the setup cfg file. I have made several attempts to ask on AMD forums but no one was able to tell.
 

ishaankaushik

Prominent
Sep 7, 2017
133
2
595
1
Post your system specs. You may be trying to install the wrong driver
My specs-
CPU-Ryzen 3 1200
GPU-RX 460 4GB
PSU-VS 450
MOTHERBOARD-AB350M GAMING 3
OS-WINDOWS 10 PRO 64BIT
RAM-16GB DDR4
Also if you look at the last 10-20 lines you can see that the GPU fails to start when it just begins to install the driver. What could be the reason for that?
 

ishaankaushik

Prominent
Sep 7, 2017
133
2
595
1
try downloading and installing the non-whql-win10-64bit-radeon-software-crimson-16.11.5-nov25

I had problems installing Adrenalin ones myself, my craptop likes the crimson drivers
But all the games that I play now will stop working. There is one thing I can try but I do not know if it is safe. I can change the DGPU workaround setting in the setup config file for my AMD drivers from true to false. I cannot understand why the Dedicated GPU or DGPU fails to start as reported by the log. Is the whole RX 400 series flawed? I have heard complaining people a lot about issues with the RX 400 series. It could also be my card only but I replaced it so that should not be a problem.
 

ishaankaushik

Prominent
Sep 7, 2017
133
2
595
1
why would your games stop working though? if those drivers install and run, your games should work.
These drivers add support for new games and if I do not upgrade drivers (which I have tried) all the newer games start crashing with errors. If you have AMD GPU can you post the settings for setup config file which can be found where the installer extracts files. It is located in the folder named config.
 

ishaankaushik

Prominent
Sep 7, 2017
133
2
595
1
honestly mate, if vcredists are not installing, you need a clean windows installation to start with. I recommend following Tom's Guide on CLEAN WINDOWS 10 INSTALLATION

Back up data and follow those instructions. All should work unless you have a bonafide HARDWARE issue.
I think I should wait for the next AMD chipset drivers update which will use a newer version of visual c++. The visual c++ 2015 and 2017 are the only ones which have same version number and thus they conflict. Regarding my GPU I think I should throw away the AMD GPU due to their poor drivers and get a 1650 instead.Windows clean install will surely not help as I have tried that before several times.
 

Mandark

Distinguished
Sep 13, 2002
1,829
193
19,990
16
those two redists are unique. they share nothing. you don't know how a redist works. It's used by applications built with that particular version of visual studio. the very fact that you can't install BOTH tells me your windows is probably hosed. seen this a million time if I've seen it once.

give me the links where you downloaded them. what you are saying isn't possible. here are links for the latest 2015 and 2017. see if they install

https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads
 
Last edited:

ishaankaushik

Prominent
Sep 7, 2017
133
2
595
1
those two redists are unique. they share nothing. you don't know how a redist works. It's used by applications built with that particular version of visual studio. the very fact that you can't install BOTH tells me your windows is probably hosed. seen this a million time if I've seen it once.

give me the links where you downloaded them. what you are saying isn't possible.
Here is the link-https://support.microsoft.com/en-in/help/2977003/the-latest-supported-visual-c-downloads
 

ASK THE COMMUNITY