werird micro stutters and screen tearing on fortnite

Sep 9, 2018
20
0
10
0
so i have built my pc a couple months ago and fortnite has never ran very god on it.

my build
cpu ryzen 7 2700
gpu gtx 1050
ram balistix sport ddr 4 8 gb 2400 mhz
motherboard asus prime b350 plus

that is my build

so i have been trying to play fortnite but the experience is very bad
i get lots of micro stutters and not smoothe gameplay
it seems to be all fixed when i turn on v sync but i hate using v sync because it has lots of input lag and is not responsive if anyone has any fixes on what could help fix the tearing and micro stutters please help me reolve this. btw my monitor is a 60 hz.
also is it possible that it is because my pc is a gpu bottleneck?
one more thing all other games like rainbow run good.
 

norcalsc

Respectable
is that a single stick of ram? if yes that's most likely your issue (single channel). what you need is a 16gb 8gbx2 kit 3000mhz or faster. your performance should be drastically better and smoother. all other games run good you say?
 
Sep 9, 2018
20
0
10
0


yes all other games i have played do not have this issue
i have 2 4gb sticks of ddr4 wich yes are 2400 mhz
 

boju

Champion
If vsync fixes the issue and hate input lag there is a trick you can try. Not sure why other games are fine though, maybe it's because you're not so much over the refresh rate?

Anyhow, couple things to try.

* enable fast sync in NvidiaCP under vsync options

* Cap frame rate to 59 and enable vsync in NvidiaCP. Nvidia's vsync overrides the game's own vsync so turn vsync off ingame. Or vsync in NvidiaCP to application control and use in-game vsync options.

Capping to 59fps adds a phantom buffer which you shouldn't get input lag but still see vsync smoothness without it dropping frames as you would think capping to 59 would do being below 60hz. It doesn't, fps stays at 59.

If cant set 59fps using Fortnite's fps cap, can use Msi Afterburner or Nvidia Inspector. I'll link Inspector version with fps limiter because there's another version without it.

Inspector: https://www.guru3d.com/files-details/nvidia-profile-inspector-download.html

Set target frame rate to 59 and hit apply button near top right corner.
 
Sep 9, 2018
20
0
10
0


hi thanks for the reply how exactly do i enable fast sync or does my graphics card not support it ?
 

boju

Champion
Should support fast sync, it's under vertical sync option in manage 3D settings.

Options should list

Use the 3D application setting
off
on
fast

fast option is fast sync.

Older driver versions had additional options such as adaptive sync but if on latest drivers the options should look like
 
Sep 9, 2018
20
0
10
0


ok i have turned on fast sync and will try it but i must be on an older driver cause it shows adaptive
how am i on an old driver if uodate the drivers often and have updated them using geforce experience
 
Sep 9, 2018
20
0
10
0


ok i tried 58 it said that it may improve input lag on v sync 60 hz
and it isnt stuttering but is still not very smoothe
the guy above said it is a ram issue do u think that may be the case
i have 8 gb of ddr4 at 2400 mhz
 

boju

Champion
Your ram is in dual channel config so thats fine. He was getting at if you only have 1x8gb it'll be in single channel.

This hasn't anything to do with system ram just your frame rates are much higher than your monitor's refresh and it's normal to not see smooth play back. Need to look at your other games you're playing and their frame rates. Closer you are to 60fps the better it'll look.

In the past ive tried fps 59 and had vsync on (not fast or adaptive) and vsync options in game turned off and it gave me good results. Just checking because im surprised, i guess it wont work for everyone but checking if you got it set right.

--

There are guides how to setup Fortnite, maybe have a look at those.

 
Sep 9, 2018
20
0
10
0


ya i have 100 plus fps in rainbow six seige i have seen it in msi afterburner and i have smoother gameplay and performance in that game
 
Sep 9, 2018
20
0
10
0


and other people say that getting a 144 hz onitor can help or should i just save up for g sync
 
Sep 9, 2018
20
0
10
0

you said the closer to 60 i am the better and smoother it is. thats what i am confused about because if i set alll low settings and turn off v sync i will have no input lag and no stutters and will have smoother gameplay.
but if i put all epic settings and get really close to 60 fps it is so much worse than anything else
 

boju

Champion


Screen tear and input lag was your initial problem. Fps over the refresh rate of a monitor will tear, its fact. The reason for vsync is to sync the monitor so you don't get screen tear but it introduces input lag.

Some games if you're close to 120fps on a 60hz screen it can look 'smooth' because frames are even and refresh isn't noticeably messed up. 60Hz screen can only show 60fps..

Increasing graphics settings to try lower fps output can help but lets not forget a 1050 is low end sorry to say. So you couldn't really increase quality without fps loss.

 

boju

Champion


Don't know, i didnt click it. It's jumble with a link and 1 post history which is this post. Better do a virus scan and shouldn't have said you clicked it, because now this person knows you did.
 
Sep 9, 2018
20
0
10
0


right
 
Sep 9, 2018
20
0
10
0

so it is normal that my performance gets very much worse by raising my graphics settings to get closer to the monitors refresh rate or is it cause i have a low end card and it cant handle the settings i was throwing at it

 

ASK THE COMMUNITY

TRENDING THREADS