Question What is causing weirdly slow download speed?

Status
Not open for further replies.
Oct 2, 2019
2
0
20
0
Recently, my downstream speed is acting quite weirdly.

Situation:
  • ISP delivers 300 mbps internet connection.
  • When speed testing, I reach around 170 mbps.
  • When I am really downloading a file from any high-speed server, I get about 30 mbps.
  • Downloading using different computer with very same connection and cable is fine and full-speed.
  • I booted Ubuntu Live CD and do speed test. I have perfectly fine 300 mbps in Live CD OS.
  • So I am currently pretty sure this is not ethernet card, cable, modem or ISP issue.
  • Described behaviour above applies for Google Chrome, Mozilla Firefox and even for running virtual machines.
  • I have fully updated Windows 10 and Intel Ethernet I219-V card.
  • I don't check it everyday but I believe download speed was really 300 mbps in Windows 10 at least a few months ago.
  • I did not install any "optimizers" or anything suspicious. Also, it doesn't seem anything is "silently eating" my connectivity; when not downloading, adapter meter is quiet.
What I've tried so far with no success:
  • To do obligatory malware check (nothing found).
  • To disable Windows Firewall.
  • To switch Windows account, to boot in safe mode.
  • To disable QoS in both – Windows group policy management and adapter settings.
  • To disable "Receive Window Auto-Tuning Level" Windows feature.
  • To use high-speed VPN connection.
  • To restart router.
  • To tweak values within "Intel PROSet Adapter Configuration Utility". Everything had been default, I've tried to change values of "Large Send Offload", etc. Since nothing helped, I returned everything back to default.
  • To install 3rd party antivirus and firewall because I hoped it would override possibly faulty Windows checks.
I will be so happy for any ideas what is throttling my Windows OS 4 MB/s instead of desired 40 MB/s.
It drives me crazy. :D Thanks.
 
Oct 2, 2019
2
0
20
0
Oh! I fixed it on my own.

I found someone recommending TCP Optimizer utility. I decided to give it a shot; let it run with optimal setting, and after fixing a few values in registry, it instantly helped.

Well, I spent some time comparing my old faulty values with my new working values. And it turns out... somehow, I had disabled "Receive Window Auto-Tuning Level" feature all the time and this was the very problem.

Running command to fix it:
Code:
netsh interface tcp set global autotuninglevel=normal
(just changing value to disabled brings me back described problem situation).

Since my case is closed, may I ask mods for marking this topic SOLVED, please?
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS

Latest posts