• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question When i install my gpu the system don't power on

Jul 7, 2020
5
0
10
0
I recently bought sapphire rx 470 4gb, it had a broken fan so i got it pretty cheap. However even after fixing the fan gpu won't work, when i install it in the computer the whole system don't power on.

I decided to open and throughly clean the graphics card and i noticed that these 8 pin are solitored together.

https://ibb.co/tZcgf8d

Is it normal?
How do I fix it?
 

puw2

Respectable
Sep 25, 2017
466
97
1,840
24
I recently bought sapphire rx 470 4gb, it had a broken fan so i got it pretty cheap. However even after fixing the fan gpu won't work, when i install it in the computer the whole system don't power on.

I decided to open and throughly clean the graphics card and i noticed that these 8 pin are solitored together.

https://ibb.co/tZcgf8d

Is it normal?
How do I fix it?
Thats a horrible soldering job someone has done, try to seperate them and see if it works. Very easy job to do.

All you need is a soldering iron, solder wick and new tin just in case you take too much off.
 
Reactions: HMZ_Rajput

ASK THE COMMUNITY