Question Why does this monitor constantly automatically choose the Asus sound driver?

lynspottery

Distinguished
Nov 29, 2011
244
1
18,695
3
I purchased the Asus ROG Strix XG32VQ 31.5 monitor recently. BUT, it kept loading up the Asus sound drivers and I had to finally disable them in the sound link in my control panel. Because this monitor does not have speakers, why does it automatically load up the driver and select it for use?

Each time I unplugged to move the monitor, it changed my sound from current to Asus. Have had it happen twice now and each time I had to manually disable the Asus sound in order for my system sound to finally kick in.

Why is it doing this? I would assume my system would take priority...so how do I fix this without having to manually change it after each time I move the monitor?
 
windows autodetects new audio devices and sets them as default (for easy switching headsets, etc)
no idea if it can be disabled?
u can disable audio on hdmi/display port through gpu control panel settings
or disable amd/nvidia hd audio device in device manager
 
i did some googling

open regedit
either search for EnableDynamicDevices
or go to :
HKEY_LOCAL_MACHINE\SYSTEM\Setup\Upgrade\PnP\CurrentControlSet\Control\DeviceMigration\Devices\HDAUDIO
here u will see few folders (all your hd audio devices like nvidia/amd/realtek)
find one for your GPU (based on vendor id) click through it till u open driver, -> global settings
on right side set EnableDynamicDevices to 00 00 00 00

u can do it on all your hd audio devices, but u will loose hot plug headset detection if u disable it for your soundcard
 

lynspottery

Distinguished
Nov 29, 2011
244
1
18,695
3
Thank you. I have no speakers in my pc, but use the green circle plug opening in the back for my external speakers. For a long time this was not a problem until I got this new monitor.

In the past I had to reinstall my nVidia drivers whenever Windows updated and overwrote the newer ones I already had installed. The audio driver Windows used was always older or an off model driver...which was a pain.

But this is new. I went into the sound setting from my control panel which is where I was able to disable this audio. I double checked the device manager and it does not show up there now. Here is a link to the image to show how I did it.

View: https://imgur.com/a/4dbSE8u
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS

Latest posts