Question Why is "Do not Disturb" turning on every time I restart my mac?

Nov 4, 2020
16
1
25
0
Hi!

I am using Big Sur OS and everytime I restart my computer "Do not Disturb" is automatically on. This is really annoying because I need to turn it off manually every time, Is there a bug or? I have seen settings at "Settings -> Notification -> Do not Disturb" all boxes are ticked off.

How to fix this?

Thanx!
 

velocityg4

Illustrious
Funny, I didn't even realize this was an issue as I set Do Not Disturb to always on.

Anyways, all I'm finding is a bunch of threads of people complaining about the same issue but no permanent solution to get Do Not Disturb to remain turned on in Big Sur. I'd say for the time being. Until Apple acknowledges and fixes the issue. You'll need to keep manually turning it back on by whatever means you found.

I'll just add. Besides the required restarts for OS and software updates or installing some new software. There isn't much reason to restart or shutdown a Mac. If this is something you're doing regularly out of habit. It shouldn't be necessary.

Edit: Just had a thought. Maybe this is something you can make an Automator routine for. Try creating an Automator routine for the tasks you perform to restart Do Not Disturb. Then add it to your login items.
 

spinningstill

Reputable
Jan 15, 2018
318
9
4,915
48
Hi!

I am using Big Sur OS and everytime I restart my computer "Do not Disturb" is automatically on. This is really annoying because I need to turn it off manually every time, Is there a bug or? I have seen settings at "Settings -> Notification -> Do not Disturb" all boxes are ticked off.

How to fix this?

Thanx!
Do you use it on your phone?

Also would check the new notifications center top right near the date and time.
 
Last edited:
Thread starter Similar threads Forum Replies Date
M macOS 2

ASK THE COMMUNITY

TRENDING THREADS