[SOLVED] Why is my ethernet connection dropping (but not wifi) and causing my pc's to freeze?

Nov 1, 2021
Alright so, just moved in with my girlfriend and we are having quite a few internet issues:
ISP: Spectrum
Her package before I moved in was the 200 down (unlimited devices)

So prior to moving in, her wifi was very spotty and would even go out for several days/weeks at a time. Her router was an old nighthawk... I don't remember the model, but it was like 5-7 years old. I restored the router to factory settings, changed the network name and password and that seemed to kinda fix the issue, but the wifi was still spotty during some days/times etc.

So fast forward to me moving in. I assumed the router was just going "bad" and decided to purchase a new one. Moved the modem (spectrum provided modem) to a new location and used a new coaxial port. The router I purchased was the ASUS AX5400 Dual Band RT-AX82U, but for whatever reason, I could not get the internet working. The error message in my router control panel said "Your ISP's DHCP does not function properly". I read about some potential problems online and called my isp and requested they do a factory reset on my modem. That didn't fix the issue, so I called them again and got a tech to come out to check it out.

He claimed the coaxial port outside was not connected to the location I moved the modem to and so he "connected" it. Before he arrived though, I switched the router back to the old nighthawk for a few minutes and my girlfriend swears the wifi connected on her phone. I personally am unsure if it worked or not, but whatever. Anyway, so the tech came in and did the basic troubleshooting they always do (hooked their signal tester to the modem and he said it was working, also checked the coaxial cable and that was working, plus we also tried using different ethernet cables and we still couldn't get the internet working). I then unhooked the router and hardlined my pc straight to the modem. It connected to the internet, so we determined it must be an issue with the router, or so we thought.

Both of us did several resets on the modem and router and still couldn't identify the problem, so I just decided to return the router and get a new one and see if that would fix the issue. Also to add, while the tech was here and we were testing things, I upgraded our internet package to the gig package. I tested out the speeds while my pc was hardlined to the modem and it was already getting around 900 down and 40 up.

So I ran back to bestbuy, returned the ASUS router and exchanged it for a Netgear Nighthawk AX4200. I came back hooked it up and ran through the setup and our internet started to work. So this made me believe it was definitely the router and now all of our problems would be fixed.... but nope. So anyway, the last 3 days (all while one of us were streaming, our internet "goes out", but not our wifi. All of the pc's we have connected completely freeze and force us to manually restart them, because they are completely unresponsive, alt f4 doesn't work, can't access the task manager, cant alt tab or anything. No lights have blinked on the router or modem, neither the netgear app or spectrum app report anything wrong with our connection, but our internet goes out (the three pc's we have connected to the router).

Upon restarting all the pc's my gaming pc is connected to the internet automatically, but the other 2 won't reconnect. Network diagnostics comes back with the results to "reset the ethernet adapter", if you troubleshoot the issue, it comes back with the "troubleshooting was unable to automatically fix all of the issues found" You can find more details below." and then below it says under problems found: "ethernet doesn't have a valid IP configuration" and it says failed and "investigate router or broadband modem issues" and that also says failed.

I have tried to uninstall the network adapters on the pc's and allow them to be automatically reinstalled upon restarting, but that doesn't fix the issue either. The only way to get the other 2 pc's back on the internet is by rebooting the router. If I reboot the router, they both reconnect right away.

Network Details:
  • Dynamic IP's
  • Changed the router login and password from default Changed the wireless network's name and set up a password
  • Brand new Router
  • Brand new ethernet cables
9 Devices are listed as attached Devices:
3 hardlined
  • My game PC
  • My stream PC
  • Her Game PC
6 Devices connected wirelessly
  • LG TV
  • Nintendo Switch
  • Galaxy tablet
  • Google home
  • Elgato key light
  • My phone
Other info: I used cloudflares DNS Servers for my primary and secondary DNS
Router Log Info: I am not too familiar with router log info as I haven't really checked it much in the past, but the 3 things I see happen are these.
  • [WLAN access rejected: incorrect security] from MAC address 34:20:03:59:54:0b (This happens 5-10 times per minute, every minute )
  • [DoS attack: RST Scan] from source,port 443
  • [DoS attack: snmpQueryDrop] from source,port 16987
The last 2 both happen a few times an hour and always seem to occur right around the time when our
internet goes out.

How can I fix my internet issue and how is losing connection causing my pc's to completely freeze?

TLDR: My 3 pc's keep freezing and disconnecting from the internet, but my wifi doesn't go out. Neither my router or modem display any indicator lights that signal lost connection and their apps say connected and online as well. Why does this keep happening and what can I do?

Also, this has not happened a single time while someone wasn't streaming. The electrical in her house isn't the best. We have popped a breaker in the kitchen and I have noticed some outlets in the house spark when plugging something in to them (my next project to work on). The router, and modem are both plugged into a surge protector, as well as all three of the pc's and her pc is on a different breaker. No clue if this issue could be something electrical related, but at this point I'm very lost on what the issue could be.
Your router sounds like it is getting confused from legit web sites and registering them as attacks. See if the router has a firmware upgrade. Also try unplugging one device at a time to see if it stops this behavior. Honestly you may be overwhelming the router with that many devices. I would try with maybe 4 devices to see if it stops. And then add one at a time to see where the overload, if that is the probelm, starts with how many devices.
Nov 1, 2021
First off, thanks for reading through my entire post. Second, I have checked for firmware updates and none are available. All the devices I mentioned are just total devices connected. When we are losing connection, only the pc's were being used.