Question Why is Premier not using all the resources? (it's slow)

Oct 25, 2020
5
0
10
0
Hello guys,

I am mostly doing photo and video editing on my Lenovo Legion 5 (4600h, 1650ti, 32Gb Ram @ 3200Mhz, 512GB SSD) . I can see in HW Monitor and Task Manager that the CPU is only used for 40%, only 10 GB of Ram is being used (although Premier is allowed to go up to 26) and the 1650Ti has 0-1% utilization.

This barely changes when doing tasks such as color correction, Neat Video (De-Noise), Warp-Stabilization, Playback and Export.

I am especially surprised about the 1650Ti utilization - I already disabled the iGPU and set hardware acceleration on in the settings, the the usage of the GPU goes at max to maybe like 5% (I haven't seen anything higher in the Task Manager).

I read online that Premier likes to have 4GB of VRAM but it doesnt seem to use anything close to that.

Problem is the software is slow, playback only works smoothly at 1/4 (and not at all after using de-noise) and exporting takes forever, all while I can see that Premier is hardly using the resources it is being provided...

Other CC programs (Photoshop, Lightroom) run fine and as expected; Premier crashes 10 times a day.
I bought this laptop so that Premier can finally stop being so whiny (came from a Laptop with a 7500U and 620HD graphics) - yet it hardly performs much better :(

HELP!
 

Ralston18

Titan
Moderator
Have you tried reinstalling Premier?

Any recent updates to the software?

Look in Reliability History and Event Viewers for any error codes, warnings, or even informational events relate to the Premier crashes.

10 crashes a day should be a fairly visible pattern. And likely traceable back to when the crashes began.

Start with Reliability History much more user friendly and remember you can right click errors for more information.
 

ASK THE COMMUNITY