Question Why wont my pc send any signal to my pc after i moved even though it worked perfectly before?

imspringin

Commendable
Dec 31, 2016
13
0
1,510
0
I recently moved and I made sure that my PC was wrapped up tight so that it wouldnt move. It worked perfectly before I moved but now my monitor shows "no signal". I plugged my monitor into my laptop and it worked fine so I know it must be the pc.

SPECS:
Processor: 2.8 GHz Core i5 8400
RAM: 8 GB DDR4
Hard drive: 1 TB Mechanical Hard Drive
Graphics Coprocessor: AMD Radeon RX 580
 
Last edited:

Math Geek

Glorious
Herald
did you "wrap it tight" on the outside of the case or inside the case as well?

most likely something came loose inside during shipping and you need to reset it. i'd suggest opening the case and making sure all the parts are properly seated and plugged in.
 

imspringin

Commendable
Dec 31, 2016
13
0
1,510
0
did you "wrap it tight" on the outside of the case or inside the case as well?

most likely something came loose inside during shipping and you need to reset it. i'd suggest opening the case and making sure all the parts are properly seated and plugged in.
Just checked everything then tried restarting it and still no signal.
 

Math Geek

Glorious
Herald
did you try plugging the monitor into the motherboard instead of the 580? it's possible being unplugged for long enough reset the BIOS and it turned off the PCIE slot.

somewhat unlikely but a possibility and a quick test.
 

ASK THE COMMUNITY

TRENDING THREADS