Wifi doesn't have a valid IP configuration and is showing limited.

Status
Not open for further replies.

Shamrock27

Honorable
Oct 13, 2013
1
0
10,510
0
Wifi won't connect with lap top, showing limited and troubleshooting says wifi doesn't have a valid IP configuration. Running windows 8. Wifi works with iPad, just not laptop. Have tried any suggestions that I have found to no avail. Has anyone got this sorted?
 

Emerald

Polypheme
Moderator
delete the SSID profile under Mange Wireless Networks in the Network and Sharing Center, and then try to connect to the SSID again.

If someone used the WPS option on the router to connect a device it will reset the wireless password.
 

sergioservellon

Honorable
Dec 16, 2013
1
0
10,510
0
1. Right click wireless icon.
2. Left click on the limited wireless connection.
3. Left click on Properties.
4. Left click on configure.
5. Right click on 802.11n channel width for band 2.4
6. Right click on the Value.
7. Change the value to auto.
8. Click OK.
9. Close all of the other wireless networking windows and good luck.
 

deadboy619

Distinguished
Oct 3, 2011
14
0
18,510
0
I had the same problem. I solved the problem by connecting my PC through the cable, going to the router page and changing the wireless SSID and password.
 

Christopher Nuzzo

Reputable
May 15, 2014
1
0
4,510
0
Perfect solution. Thanks for your help!


 

Yetidog13

Reputable
Jun 3, 2014
1
0
4,510
0


This didn't do anything for me. The same problem still occurs.
 

Terrensa

Reputable
May 29, 2014
17
0
4,520
4
Do you have anything else connecting to the router that actually works (either wired or wirelessly)?
Have you tried power cycling the modem and the router?
Have you tried an ipconfig /release and then an ipconfig /renew after power cycling both?
 

amandafromkc

Reputable
Jun 9, 2014
1
0
4,510
0


Can you please explain using laymans terms, i am no where close to computer guru however getting real frustrated. my computer connected to wii pefecty two days ago, then i import some pictures from my camera and all of a sudden my laptop shows limited connection. invalid ip config. and problem with wireless adapter or acess point. we have like 4 other devices that work just fine off our connection. so frustrated. uugh
i did connect the ethernet cable to the back of the laptop then it worked. i disconnceted it then entered a valid ip address i got off you tube undet the wifi setting. back to square on. LIMITED. this is making me so mad, i need my laptap for class. can you please help. i even took my computer to the geek squad and it connected to their wifi no prob. they took some malware off and charged me 60 bucks and i'm still having the issue.
 

AlexEM

Reputable
Jun 12, 2014
1
0
4,510
0


I have had the same problem and tried all suggestions I could find, nothing worked for me. My "work-around" was to set up the IP manually rather than via DHCP, disable DHCP, enter an unused IP compatible with your network, mask is "typically" 255.255.255.0,
 

jazzman10

Reputable
Dec 8, 2014
1
0
4,510
0
I tried many of the solutions posted but ultimately, if you used to have a working internet connection with a valid IP configuration and now you don't but nothing seems to correct the problem, the only thing that worked for me to restore a valid IP configuration was to use a system restore from an earlier date with a known working configuration. Give it a try.
 

ddendukuri

Reputable
May 3, 2015
1
0
4,510
0
I have a Dell Inspiron 3000 series using Windows 8. I solved the Limited WiFi problem by manually setting my IP address. None of the other (netsh, resettign adapter etc.) solutions worked for me.

1. Open Network and Sharing Center in Control Panel
2. Open your WiFi connection
3. Click on Properties
4. Click on Internet Protocol Version 4 and then click on Properties
5. Set IP address manually to 192.168.1.x (I chose x = 14)
6. Set Subnet mask to 255.255.255.0
7. Set IP gateway to 192.168.1.1
8. Choose DNS servers as Open DNS (208.67.222.222 and 208.67.220.220)

Worked like magic for me after 3 hours of frustration
 

jacobminz

Reputable
Jul 18, 2015
1
0
4,510
0
If the problem doesn't get solved by resetting network adapters and all configs...then
-I would suggest(100% working)

1.go to network and sharing

2.left click on the connected wifi connection.

3. Click on properties

U will see a list of items which is used by the connection
...so u need to look for ur antivirus firewall.example-avast firewall or kaspersky firewall...which is active

4.uncheck that firewall option from the list.
5.ur connection would now show internet access guaranteed.!!!

Hope it helped u...cause my problem was solved with this!
 

Bharat Dharam

Reputable
Jul 30, 2015
1
0
4,510
0
I searched everywhere including this site/threat but no use. Then I searched this problem on YouTube and I got a video which surprisingly worked for me and resolved the issue within few seconds.! I hope this helps to you guys as well.!
P.S. I am from India and IP address/default gateway etc. provided in the below video may not work outside India. (Though, it's just my assumption and please correct me if I am wrong.!)

Here is the link. Good Luck.!
https://youtu.be/ekBhV5VeIt4
 

JoannaLannister

Reputable
Aug 13, 2015
1
0
4,510
0


Ι would like to thank you for sharing this solution.
I had the same problem and I tried everything.
Your suggestion was really useful.
 

nyanpeko

Reputable
Aug 27, 2015
1
0
4,510
0


YOU ARE A GENIUS. I tried your solution and it worked!

I thought my MSI had no hope of upgrading from Win 8.1 to Win 10 (had stupid problems like windows telling me that my graphic card GTX-965M isnt compatible, but heck i installed it again using windows media creation. Before this i gave up fixing the wifi problem and reverted back to win 8. can you imagine my frustration?) I live in Singapore and this IP thing works. Im not an IT guru and ive been googling for troubleshooting tips regarding this. What a life-saver! Now I can go buy my Xbox One Wireless controller (and the upcoming dongle which only works with win10) and game away! /cries rainbows/ I just had to post this thank you note!

P.S: After I changed the settings accordingly, the troubleshooter said it enabled DHCP on my computer.
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS