Windows 10 Auto Update Troubleshooting Thread

Page 2 - Seeking answers? Join the Tom's Hardware community: where nearly two million members share solutions and discuss the latest tech.
Status
Not open for further replies.

shravank30

Distinguished
Apr 20, 2008
28
0
18,540
1
Hi there
I have windows 10 home activated
In my last update there is a windows office update which fails to install
My query is that will it prevent me from getting and installing any further updates in Win 10 OS till this particular update is installed .?

Is there any way to cancel the update as was in Win 7 ?
Thanks for advising
 

Clariska

Honorable
Aug 6, 2012
23
0
10,510
0
If i can remember correctly.Even if you stop the service for update(work on the older win as well)it enables it again after reboot.I can't really remember as i only had win 10 for a week and rerolled to windows 7 as win 10's just a glorified windows 8 in my opinion......But MS are just going about sooo wrong with there software games etc.Forcing everything to play on x-box controller.First they are damn expensive Second Controllers suck :D and Forcing everyone to run stuff the way they want it but correct me if i am wrong...It's my pc aint it?

Pretty sure other Software companies gonna take over soon as MS are pretty shitty these days :D
 

Pisol

Reputable
Jan 24, 2015
39
0
4,540
2
Hello all. I'm having a problem with Windows 10 automatic updates on an Acer laptop.
It's an Acer Aspire with a Core-2-Duo Processor, which came with Windows 8.1. I upgraded to Windows 10 Pro and made the mistake of deleting the restore point and, by doing so, the possibility to roll back to Windows 8.
The computer was running perfectly fine until after installing an update and rebooting, the keyboard and touchpad stopped responding.
I searched the web and it seems to be a driver update issue, tried everything but nothing worked. Unfortunately I'm having difficulties to get to the boot menu and install the previous version of Windows, but I could reset the current installation of Windows 10 and now it's working fine.
I'm afraid Windows will force the update again and so my keyboard and touchpad will stop responding again.
Is there any way to completely disable these updates?
Thanks for reading!
Greetings from Argentina.
 

captaincandellight

Honorable
Oct 10, 2013
84
0
10,630
0


"No" I checked I am running Windows 10 Home and I have the option to disable automatic updates by using the above method by "jed".
 

captaincandellight

Honorable
Oct 10, 2013
84
0
10,630
0


You can't disable the auto-updater, and updates will be installed upon your next reboot (which you can schedule).


I have Windows 10 Home and it has the option to differ updates.

a) Go to settings
b) Update and settings
c) Advanced options
d) Defer upgrades

And you can disable auto updates in Windows 10 Home buy using the method by "jed" or you can also do it by doing the following and the changes stay that way even after a reboot :-

a) Go to control panel
b) Change the icons in control panel from the above right drop down option to - large icons
c) Open Administrative tools
d) Locate and Double click Services
e) When the services window opens scroll right down to the bottom. Locate and open Windows Update.
f) Click the stop button in Windows update window.
g) Go to startup type in Windows update and select Disable and click ok.

To enable Windows updates again open Windows update window again and select automatic or automatic with ( Delayed Start ) from drop down from Startup type. Then click Apply and Start.
 

captaincandellight

Honorable
Oct 10, 2013
84
0
10,630
0
Question/problem resolved.

It turns out that Windows updates are NOT installed during shutdown if the "Fast Startup" power button option is turned on. When turned off, updates are installed during shutdown just like Windows 7. Too bad this information seems to be *very* difficult to find.

See Control Panel > Power Options > "Choose what the power button does" > "Shutdown settings" section.
You are right.


 

Wagner_2

Commendable
Aug 13, 2016
1
0
1,510
0


 

naqeeb123

Commendable
Aug 16, 2016
14
0
1,520
4
Window 10 pro Insider Preview is auto update for PC it take a to long time but working perfect for me. Last time got this update and also shared my expression on some other forum see:
http://forums.standaloneinstaller.com/general-discussion/windows-10-pro-insider-preview-build-14901/
I didn't get any error during downloading updates and installation. How its suspicious! ..... Amazing for me.
 

Jackske

Commendable
Sep 1, 2016
2
0
1,510
0
[That makes more as two months that I struggle with Windows 10 Updates.
I have read all the forums but nothing helped.
Finally I found the solution.
Go to the site https://www.microsoft.com/en-us/software-download/windows10
Click "Update now".
Microsoft will install a new version of Windows 10, without changing anything in your settings and all your programs will continue to operate normally.
All your problems with Windows Update will be settled.
It takes patience because it takes a long time. But it is worth.
Jackske
 
Windows 10 Pro upgraded last night. It took nearly 2 hours to update. But that was no problem. The problem is that now my laptop has become very slow and unresponsive. When I try to open program(any program small or big) it is taking a lot of time and is becoming unresponsive. In some case it gets stuck and I have to force shut down it and restart. It is also taking nearly double time to boot.

I hate this update and hope new one with a solution shows up soon.
 

ColopiX

Honorable
Jan 25, 2014
224
0
10,690
1
Pls guys i need help.My PC for 2weeks always when i shut down it will start updating or just will restart for 2-3times on one day itself.The problem is that the updates cant install and i have to wait win to undo changes! Every day,EVERY day its doing this and i.have to shut down my pc from button or psu.I have diseabled to win automatic install updates but it doesent work..... Is there any solution to stop win 10 Pro installing something that my.pc cant handle? (i think some mobo driver is problem.because my foxconn h61mxe doesent support win 10) and i dont want to uninstall windows thx :)
 
I had same problem but instead of shutting down my update used to download again and again repeatedly but was not getting installed. Three day back new update came which got downloaded and was installed. Now that problem is solved. But now my PC is working too slow and stops working atleast twice a day. That is real bad. Don't know why Microsoft an upgrade like this but It is a real pain. The laptop which worked smoothly for year while having Windows 10 without causing any trouble is now causing a lot of pain.

I hope new update comes in soon.

For your problem ColopiX go to Disk Cleanup select drive C: and clean temporary Windows installation files.
Next time you boot it will start normally but will download update again(let it download again if it causes the same problem after download follow the procedure again but next time don't let it download).
 

Jackske

Commendable
Sep 1, 2016
2
0
1,510
0
[That makes more as two months that I struggle with Windows 10 Updates.
I have read all the forums but nothing helped.
Finally I found the solution.
Go to the site https://www.microsoft.com/en-us/software-download/windows10
Click "Update now".
Microsoft will install a new version of Windows 10, without changing anything in your settings and all your programs will continue to operate normally.
All your problems with Windows Update will be settled.
It takes patience because it takes a long time. But it is worth.
Jackske
 

CyberDevil

Reputable
Apr 6, 2015
101
0
4,710
9
I have a solution.

For Windows 10 Home users:

1. Got to 'Settings' and then to the 'Update and Security' menu. In the Windows Update area select 'Advanced Options'. In the 'Chose how updates are installed' section, select 'Notify to schedule restart' in the box below. Uncheck 'Give me updates for other Microsoft products..' and check the 'Defer Upgrades'.
2. Got to 'System' Properties from 'Control Panel\System and Security\System' and into the 'Hardware' tab. Select the 'Device Installation Settings' and in the window that appears, select 'No, let me choose what to do' then select ' Never install driver software from Windows update.' This will disable auto updating for your visual, audio and other as such drivers whenever and if Windows looks for an update.
3. No, if you're using a wireless connection with Wi-Fi, go to 'Settings' and into the 'Network and Internet' menu. Here, while you're connected to a wireless network using Wi-Fi, select that network and in the screen that appears, select 'Set this as metered connection'. This will meter your connection and Windows will not look for updates.
4. If you're wired like using ethernet, open the 'Windows Registry Editor'. Navigate to 'HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\DefaultMediaCost'. Right-click on DefaultMediaCost and click Permissions. In the Permissions for DefaultMediaCost window, click Advanced. In the Advanced Security Settings for DefaultMediaCost, click Change next to the owner. In the text box labeled Enter the object name to select, type in Administrators and click Check Names. Check the box next to Replace owner on subcontainers and objects and click OK. Back in the Permissions for DefaultMediaCost window, click Administrators to select the group and then under Permissions for Administrators make sure the Full Control Allow box is checked. Click OK to exit this window. Right-click on Ethernet and click Modify. An Edit DWORD (32-bit) Value window will open. To set the connection as metered, change the Value data to 2.

For Windows 10 Professional users:

1. All steps are similar as above.
2. To disable this later, go back to the Group Policy editor, double-click the 'Configure Automatic Updates' setting, and then change it from 'Enabled' to 'Not configured'. Save your changes, visit the Windows Update pane again, click 'Check for updates,' and then select 'Advanced options'.
I don't exactly remember what to do after this, so you can Google it.
 

J0E24

Honorable
Oct 20, 2013
110
0
10,680
0
Hey cyberdevil i have had a issue with my windows 10 updating recently. I dont think i have windows 10 home, as when i go to PC Settings, my bottom selection is update and recovery, and when i click that i dont have a advanced options area. Mine says Restart your pc to finish installing updates. Your pc will automatically restart in 1 day if you don't restart now.

For a few weeks now if i turn my pc off it attempts to update then it reverts back as it cant finish the update.
 

CyberDevil

Reputable
Apr 6, 2015
101
0
4,710
9


To check which edition and build of Windows you have, open Start type 'winver'.
Is it 'PC Settings' and not 'Settings'? If that's the case, you're probably running Win 8/8.1 or an earlier build of Windows 10 or maybe Windows 10 preview.
I guess your OS finished downloading the updates but couldn't install probably because of some technical error. If you can, I suggest updating your OS again. To remove the already installed updates, go to Control Panel, then Programs and Features and then view installed updates. Uninstall every updates you see.
Or you try to download the updates once again if it's allowing it.
 

CyberDevil

Reputable
Apr 6, 2015
101
0
4,710
9


While nothing like this happened to me on a PC, it happened on my Windows Phone. I tried to update the phone to Windows 10 from Windows 8.1 but it wouldn't let me and just show some technical error (code:80287ff, something like that). I just factory reset my phone and hurrah, it let me update. Maybe if nothing works, you can try resetting your PC if you need that update.
 

asdfffdsa

Commendable
Nov 9, 2016
1
0
1,510
0
If you're on an internet connection with a data cap, consider using traffic shaping software like Netlimiter or NetBalancer. However, be advised: do not completely block svchost.exe. Some versions of Windows 10 will detect this and force restart the PC.
 

Badaboum

Commendable
Nov 13, 2016
2
0
1,510
0


 

Badaboum

Commendable
Nov 13, 2016
2
0
1,510
0
It is possible to stop Windows upgrade: go to "MANAGEMENT", then "SERVICES" then all the way down to "WINDOWS UPDATE", and disable the service.
I did it and will keep it this way until they fix the dogdamn problem.
 

mediamenia

Reputable
Aug 21, 2015
2
0
4,510
0
Disable update and if you did not disable then let be update windows until configure all the updates.

If you have any query regarding updates errors then you may read Microsotofficesupport.org blog that will help you out to resolve your any kind of PC issues.
 

fxdroid

Commendable
Aug 28, 2016
9
0
1,510
0
In Windows 10 Pro you can also set up a Local Group Policy so you will be notified about the updates and you will be able to choose which one youw ant to install.
 

J0E24

Honorable
Oct 20, 2013
110
0
10,680
0
I posted in this a while back, I had windows 8, and did the upgrade to windows 10 through the updates itself awhile back. For awhile now my PC has tried to update itself with the Microsoft automatic updates. Every time i restart my PC it wants to update, it gets through 100% of the update and says "We couldn't complete updates undoing changes" and it takes about 5 minutes to actually let me log back in. I have tryed uninstalling the most recent microsoft update through the control panel, which seemed to work, then there was 9 new updates for windows 8.1 which it made itself restart and update and go through the same process again.

I have no idea what to do. Please help!
 

fxdroid

Commendable
Aug 28, 2016
9
0
1,510
0
So is it Windows 10 or Windows 8.1 that you are using at the moment? In December Microsoft had a problem with some of its updates for Windows 10 and this is causing a problem for the users.
 

J0E24

Honorable
Oct 20, 2013
110
0
10,680
0
After looking at what windows version I have I do have windows 8.1. Which is odd because I could have sworn I had windows 10, unless when my ssd took a crap that had my OS (windows 10) I redownloaded windows 8.1 with the cd I had.

Still have the issues with the update failures though
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS