Windows 10 does not assign letter to USB drive

i_am_jim

Distinguished
Aug 27, 2008
71
0
18,630
0
This was happening on Win8 also.

I have a USB backup drive docking device[strike][/strike].

When I remove a drive and reconnect it Windows does not assign it a drive letter. I must go into administrative tools, disk management and assign it a letter before I can use it. This is something of a pain because I swap USB drives often.

I thought this was normal until I was helping a friend and lent him a drive for troubleshooting. When he connected it to his USB drive housing it was immediately assigned a drive letter. Why does his Win10 system automatically assign a drive letter and my Win10 system does not?
 
What you've encountered is a miserable Windows glitch going back many years that's plagued perhaps millions of PC users over the years.

In most scenarios Disk Management will assign a drive letter without user intervention, however, other times it won't. And for no apparent reason one way or the other. So in the latter case the user has no alternative but to use DM to assign a drive letter. It seems it's just a crapshoot.

One thing you can try presuming you'll be using that USB external HDD docking station on a more-or-less routine basis; the next time no drive letter has been assigned, assign a drive letter (using DM, of course) way down in the alphabet, say R or T or some such. For some reason we've found there's a good chance that that drive letter will be "permanently" assigned to your present USB device by DM. At least give it a try if you're so inclined.

BTW, I'm aware of third-party "solutions" to this problem but I'm loathe to use or recommend any of them since they invariably modify the system's registry. And to make matters worse more than one has been found to employ malware of one sort or another.

 

i_am_jim

Distinguished
Aug 27, 2008
71
0
18,630
0
Thanks for your reply. At least I understand now. I don't think it happened with my Win7 system but it's been too long ago to be sure.

I'm unlikely to assign different drive letters as I have programs and batch file that automate most of my activity.
 

i_am_jim

Distinguished
Aug 27, 2008
71
0
18,630
0
To corroded:

Did you go to the link in my first post?

https://www.amazon.com/Cable-Matters-Drive-Docking-Station/dp/B0099TX7O4/ref=sr_1_1?ie=UTF8&qid=1488674799&sr=8-1&keywords=cable+matters+docking+station

If you change external drives occasionally (or in my case frequently) they are very convenient. An internal drive just plugs into the device. There's no fussing with an enclosure. If I had it to do over I would choose this one. It costs a little more but I think it's more reliable. Mine went intermittent after a few months and I had to replace it. It was covered by warranty but still . . .
 
NP, I never refer to those as docks...

As stated above, yes this happens, sometimes you can correct it by uninstalling the device form the device manager, rebooting and letting Windows "find it" again as a new device.
 

timobkg

Distinguished
Jul 27, 2009
35
0
18,530
0
This is an issue I encountered with Windows 10 as well. Fortunately, there's an easy solution that does not require any third-party downloads or registry modification.

1) Open Command Prompt as Administrator (search for Command Prompt in the Start Menu, right click, Run as Administrator)
2) Type 'diskpart' and hit Enter.
3) Once in the DISKPART command prompt (it takes several seconds to load) type 'automount enable' and hit Enter.

That should re-enable automatically mounting new volumes, fixing the issue.
 

ia3d

Reputable
Sep 4, 2014
8
0
4,520
1
This solution WORKS! Thanks.



 

Chris Bedford

Honorable
Dec 7, 2013
13
0
10,510
0
  1. Type 'diskpart' and hit Enter.
  2. Once in the DISKPART command prompt (it takes several seconds to load) type 'automount enable' and
THANK YOU THANK YOU THANK YOU

Why didn't I look for this solution months ago, I wonder. Also: how did this get turned off, I wonder. I've used DISKPART before, but strictly to remove all partitions on USB drives with CLEAN. Def never switched automount OFF. Anyway, thanks again, working, YAYYY
 

ASK THE COMMUNITY

TRENDING THREADS