Question Windows 10 Error 157 Disk # Surprise removed

realism51

Distinguished
Nov 29, 2012
76
0
18,640
1
Summary:
SSD is having Disk surprise removed problems which are causing folders to close and games to crash. No problems previously with drive, only once windows 10 was installed was there any issues noted.

Previous Computer Build:
Windows 7
MSI z-87 GD-65 MOBO
Intel i5-4670k
16GN corsair ram,
4 Hard drives: 250GB Hyper X Kingston (Held the OS), 1TB WD HD, 500GB WD HD, and a 1TB SSD Samsung 860 Evo (This was purchased like 6 months ago)
etc, (rest is not really important)
Entire time I was running windows 7, never had a problem with the drive or any drive.

Current Build:
Windows 10 1909 18363.592
MSI B450 Tomahawk Max
Ryzen 7 3700x
32GB of Gskill tridentz
Same Hard drives.

Time line of events:

Hyper X is main C drive and I put together the new system, only had the Hyper x hooked up when I installed the OS (Windows 10). Installation went without a problem.

Hooked up my drives to do some transfering around. Had some issues where I could not delete a file on the Evo so I had to take ownership of files which is odd because there was no ownership attached to it previously.

I installed Steam and attempted to start downloading and installing games, the steam launcher would keep stopping at random moments while downloading and installing the game and giving me a Write Error excuse. I checked the disk with a few tools and there were no bad sectors reported. Some files that were transfered to the drive somehow showed up as corrupted, and could not be played. When I was deleting files from the EVO I did get a message that said the recycle bin on that drive was corrupt, which was odd considering it never showed one on it. I had tested windows 10 installation on this drive before installing it on the Hyper X.

During this time I had also started updating all the drivers and installing the boards drivers and all that jazz. Still had problems with installing games and getting that write error. So I just went and formatted the entire drive and set it up as a new drive and new partion. Still would randonly get the problem. Went into drivers and rolled back the SATA driver from MSI and stuck just with the ones that Windows 10 installed as default. That appeared to solve the issue because then I could install games without getting the error write issue. I also did make sure to run cmd and double make sure all write protections were set off for this drive.

However, now I am having moments of the games (that are installed on the EVO) crashing to desktop without an error messages or just freezing in game, and file explorer being open only for it to randomly close any folders that are on the EVO. The drive doesnt ever NOT show up so I see that it is still there and connected and there are no notifications that said drive is disconnected or reconnecting. Physically I see no reason why this problem should be occuring, and as there was no issue previously with Windows 7, the only conclusion that I can think of at this point is it is a windows 10 issue.

If it was a motherboard issue, then I would be notified and see the driver missing when this happens and see it reconnecting, but I dont. I doubt it is a failing SSD, since its new and there are no diagnostics showing it is failing. I really want to give windows 10 a fair faith effort even though I sorely want to jump back to Windows 7 as it was more reliable, even without getting system updates anymore. Anyone here willing to help me pick this problem apart and find the solution?



Update
---------------------------------------------------------------------------------------------------
Used Samsung Magician to install the newest firmware for the EVO SSD. Afterwards there is now a mict.bat batch file on the root of that drive but problem persists.

Powered off and swapped the SATA connection to a different port on the MOBO. maybe faulty port. but still no change.

When playing games is when there is a major issue with files closing and errors thrown in game which say things such as resource corrupted or not available, etc, even full crash to desktop.
Event viewer always shows the Disk surprise error. .

I have made sure in power settings there are no sleep options. Gone through my MOBO BIOS for any power settings, and cant locate any that would suggest there is an ability to have a sleep or perma power option.

Ultimately I feel this is entirely windows 10 related and not the drives fault since there are no errors, health is good, scannow shows no problems, chkdsk shows it is perfect. Just that bus enumuration i guess is screwing up.
-----------------------------------------------------------

Update 2

Running through event logs, there are no errors or disk issues until after the windows update session. I'm leaning heavy on the fact a windows update broke my computer.
 
Last edited:

hang-the-9

Titan
Moderator
I have run many EVO 860, and 840 and 850, drives in computers on Win 10, never had issues with them on that OS.

You may want to backup the files on the other drive and do a clean setup on it and a new format. With 4 drives I wold start with removing the platter drives, use the boot drive and that new SSD. Do a diskpart on the SSD to wipe it, then format it and see if it still acts up.
 

realism51

Distinguished
Nov 29, 2012
76
0
18,640
1
Already did a format and new setup with the EVO, still has the problem, even after a repartitioning. All tests and even events show the drive is perfectly fine and healthy. I see errors 51, 140 a few times right prior to the disk removal. system failed to flush data to transaction log, (device which does not exist was sepcified) and the 51 is error detecting device during a paging operation

even other times I see ntfs 98 after the 157 error that tells me the volume is healthy, no action needed.


And I need those other drives, until I can afford a 3-5 TB SSD, Im stuck with my two platter disks. Besides they shouldnt have any bearing on the operation of the EVO
 

realism51

Distinguished
Nov 29, 2012
76
0
18,640
1
Update 4

I rolled back all drivers and windows updates to back to when it first installed. I disabled the paging file for C drive. There arent any errors with the recording so far, and only one error that happened at exact time i had another disk 157 error.

Tried a different SATA Cable.
most of these erros are around and from paging file which is why I turned it off. I refuse to accept that my hard drive is failing since it is only 8 months old or so, and i had no problem until I installed windows 10
 

ASK THE COMMUNITY

TRENDING THREADS