Question Windows 10 keeps freezing ?

Ninja_Sub

Honorable
May 27, 2015
9
0
10,510
0
Ok I'm not 100% sure if this is the right place to put this as it could be hardware related but windows 10 keeps freezing, mostly in a game but sometimes when I'm just on desktop. I have a gtx 1060ti 6gb and a msi z390 gaming plus motherboard. I have tried every software troubleshoot I could but it keeps freezing. Sometimes quickly and sometimes after a couple of hours the screen just freezes. I have changed out my ram, and ensured it is properly installed.

The motherboard I had just replaced but it ran perfect for a couple of weeks before this problem occurred. I have been monitoring my temps and, according to the iCue dashboard all my temps are in the green. I don't think I'm having PSU problems but I'm not really sure how to check. Wondering if it might be my GPU failing but unsure on that too. The GPU is the oldest part on my rig. Please help me, I wanna play Conan Exiles with my friends. Sorry if this was the wrong category to post this in, wasn't sure. Thanks
 
go into bios reset it to defaults or change any setting and change it back then save and reboot and see if you still get the stalls.

after that I would run a tool like this:
https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer
and see if I could determine where the system is waiting or taking up too much cpu time.
you can use this tool to suspend suspected threads to see if it is the cause of the slowdown.

when you figure out the process then you can get an idea of how to fix the problem.
for example, I have seen the search indexer on windows get confused and run in a endless loop, the fix was to kill the process and delete its database and restart the process. it was a bug in a filesystem driver where a directory was crosslinked the indexer added the files to the index, went down the directory adding the index but the cross link put it back up in the directory structure so it just went down again and the database grew to over 60 GB. Slowed every thing down and filled up the hard drive.

other times we had to dump the stack of the process to see what its problem was. (fix was to boot into bios and touch a setting and save, to force a rebuild of the database that was sent to windows for the list of hardware setting that was in use.)
 
Last edited:

ASK THE COMMUNITY