Windows 7 Memory Problem


Oct 31, 2011
I've recently purchased 2 modules of Kingston DDR2 PC6400 DIMM RAM to upgrade my RAM from 2GB to 4GB on my Shuttle SG33G5 running Windows 7.

However, when I look at the system properties, it displays "Installed RAM : 3.24GB" instead of 4GB. I've read other posts with similar problems, but theirs displays 4GB installed RAM (correct), but 3.24GB usable. Mine doesn't even mention the usable amount, and I imagine if it did, it would be lower than 3.24GB. I am using onboard VGA graphics, but the BIOS is set to only use 128MB for that, which does not account for the difference. Anyhow, surely this would only affect the usable amount of RAM, not the installed amount that Windows reports?

If I run msinfo32.exe, it tells me the "Installed Physical Memory (RAM)" value is "Not Available". If I run CPU-Z, it tells me I have 4GB total (correct), but I have a feeling it is just querying the RAM modules themselves, which are reporting what they think they are providing as per their specification, but not necessarily what they are providing to the system. I've run Windows Memory Diagnostics which reported no faults and I've even swapped the modules around to no avail. If I reinstall the two old modules (2GB total), Windows reports 1.99GB installed memory, which is correct. I am now suspicious that there might be a fault on one or both of the new modules which means they're not able to provide their full amount of memory to the system. Is a fault like this even possible?!

Any help would be greatly appreciated!



David 617

Apr 12, 2011
do you have a 64 bit copy of windows? sounds like you only have 32bit. a limitation of 32 is that only 3.2 gb of ram can be read.

to check - rt click on computer> properties. system / system type. if you have 64 bit it will say so under system type