• Hey there, Guest! Share your idea for a new trophy in the forums and win bragging rights and a $100 Amazon gift card! Check out the New Community Trophy Contest here!
  • Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

Windows 7 won't boot after new motherboard but can get to BIOS?

CallumCJ

Honorable
May 10, 2012
10
0
10,510
0
Hi I need some help asap, I just swapped out my old motherboard since it was quite rubbish (really old packard bell m-atx board) for a brand new ASrock P5B-DE motherboard.

However after installing the board and plugging everything back in exactly where it came from on the old board, the PC cant boot into windows 7 64bit. I've tried the repair option and it doesn't work.

I've tried disabling and enabling various options in the BIOS. Also tried removing the memory and only using 1 stick then tried both sticks in different slots and that hasn't changed anything.

I've tried inserting my Win7 CD but it doesn't seem to boot from the DVD drive (will keep trying to see if it can).

System specs are:

Intel core 2 Quad Q6600 @ 2.4GHz (using Freezer Pro7 CPU cooler)
Samsung DDR2 800mhz Ram (2GB x 2)
160GB 7200RPM Hitachi HDD
ATI (XFX) 5830 1GB GPU
Zalman 500W PSU


my next point of call (thanks to some google searching) is to try a lower end GPU as i've still got my Nvidia GTS 250 and doesn't use any external power from the PSU.

Any help would be appreciated as I need the computer up and running ASAP

Cheers

(P.S. I'm not overly bothered about doing a clean install as i recently did one anyway and I haven't had a huge amount of programs installed on the pc since then. But if I can fix this without a clean install that would be preferable)
 

CallumCJ

Honorable
May 10, 2012
10
0
10,510
0
It was a new version of win7 64 (not OEM) i installed on the pc before i decided to upgrade the board (it was running 32bit before that) just a guess but, the code will still be locked to the old mobo yes? if it is locked that's ok because i can get a code for free from my university.

 

It may fail the Activation due to the changes, just take the Phone option, it's automated and a bit cumbersome, involving lots of numbers entered on your handset then on to your machine, but it should be successful.
 

rdc85

Honorable
Apr 29, 2012
2,943
0
13,460
218


+1


windows do not like mobo change, need clean install no other way around.........
 

dmd9

Honorable
Aug 5, 2012
2
0
10,510
0


I have the exact same problem - upgrading mobo from crappy MSI with
intel chipset, to better Asus board with nvidia chipset. Can I not
install the new mobo's vendor's driver pack on the machine with the
old mobo installed (so it boots), install the new board,
then....voila? Windows shouldn't use the drivers unless it detects
the hardware, yes? This is, I believe, an OEM copy. The OEM disk
won't boot, however, I did get a linux cd to boot. I haven't
checked the part number for the disk yet, but I guess it could be some
kinda upgrade DVD, but I thought m$ did away with that a while ago.
Anyway, I'd like to avoid a clean install if at all possible.

Not sure if it's taboo for me to resurrect this thread. if it is, I
apologize; I found this extremely informative.

 

What you're suggesting sounds like a nightmare! One installation with 2 sets of drivers? Recipe for disaster... You could try this, but you lose your activation
http://www.sevenforums.com/tutorials/135077-windows-7-installation-transfer-new-computer.html
and if the machine came from a major vendor with Win7 installed you stand little chance of successful activation. Either way you'd be advised to do a clean install, download ISO from here
http://forum.notebookreview.com/windows-os-software/604187-legal-download-digitalriver-windows-7-sp1-13-languages.html

and burn to a DVD.
 

dmd9

Honorable
Aug 5, 2012
2
0
10,510
0


just for giggles, can you explain why that sounds like a nightmare compared to backing up 100GB of data? Like I said, if windows doesn't detect the hardware, it's not gonna use the drivers yes? Even if they are loaded in the kernel at boot time, they won't be called. Am I incorrect in stating that? Once I stick the new mobo in, can i not just remove the old drivers and vendor toolkit?

Also, why have I never had this problem with win7 ultimate?
 

Just going on other's experiences in trying to do something similar. 100 Gb data? What size drive? Do you have enough space to create a new partition and install the new copy of Windows there, then remove the old Windows at your leisure? Would save a lot of hassle...Plus there could be problems loading driver packs which will not install because they can't find compatible hardware. If you can create a new partition, at least try to activate on the old licence, you wouldn't be the first to succeed with telephone activation in similar circumstances, nothing ventured nothing gained!
 

axehead15

Honorable
Apr 9, 2013
444
0
10,810
24
I ended up just plugging in the old mobo and uninstalling all drivers for it. Then when I put the new mobo in, it started right up so I could install the drivers for that one.

The only way this wouldn't work is if the old mobo is bad. For upgrades this is the best way to do it.
 

herpderpalot

Honorable
Dec 10, 2013
2
0
10,510
0
Guys. Boot to ultimate boot cd on a thumb drive (freeware: http://www.ubcd4win.com/)

Go to the registry tools, and use "Fix HDC" to fix the Hard Drive Controller when replacing your motherboard.

It was designed in the XP days but works just fine on Win7. Just did this yesterday, worked like a charm.
 

missionsbound

Honorable
Feb 13, 2014
12
0
10,510
0
Any easy solutions yet? I'll be darned if I have to lose my old C: drive. I switched mobo and CPU and now I get this blue screen when I try to boot that Windows file. I reinstalled Windows on another drive an it worked. The old C: drive is visible but I can't access none of the files on it. The only thing I can attribute to this disgrace is that the drive letters have switched somehow. Would changing them back fix this?
 

hangfirew8

Distinguished
Jun 19, 2009
108
0
18,680
0
If you can get it to boot either the Windows Rcovery disc (generated from a running copy of Windows 7) or get to the recovery screen from your existing HDD install, you don't need to uninstall. Follow this procedure:

http://www.dowdandassociates.com/blog/content/howto-repair-windows-7-install-after-replacing-motherboard/

Basically it involves getting your drivers into a readable format (not .exe's or .zip's) on a CD-R or DVD+/-R, and then entering this command and rebooting:

dism /image:c:\ /add-driver /Driver:X:\ /recurse

Where "X:" is your optical driver (probably D or E).

 

missionsbound

Honorable
Feb 13, 2014
12
0
10,510
0


I reinstalled.

Thanks
 

dave1310

Distinguished
Aug 4, 2010
42
0
18,540
1
The Dowd&Associates article ( http://www.dowdandassociates.com/blog/content/howto-repair-windows-7-install-after-replacing-motherboard/ ) mentioned above is a great one. BUT, before you go through all those steps try this one first.

Enter Bios and go to the drive configuration screen.
If the setting is for AHCI, change it to IDE and vice versa.
Save and exit. Restart computer is the exit doesn't automatically.

You should see that it goes past the point where the bsod and reboot took place fairly quickly. Then wait as it will take a while for windows to churn through the changes and get to your desktop. Then you can load the new drivers from the DVD.

This, of course, doesn't work every time but it does often enough to make it worthwhile to try it. As I understand it, if your old motherboard ran your hard discs as IDE, you have to set the new mobo to IDE to get your hard drives to be recognized. If it comes pre-configured to AHCI, your BSOD is telling you no op system is found. (Which makes sense if the hard drive isn't recognized.) The reverse is true also; if your old board ran AHCI and its preset to IDE again your drive won't be recognized, blah blah!

OF course, if you get the BSOD and an immediate restart, go ahead with the Dowd&Assoc. article AFTER you change the BIOS back to the original setting.
 

jex5000

Reputable
Sep 19, 2014
1
0
4,510
0
Just make sure u plug in the power button. To motherboard , fill your ram slots, and plug hard drive and CD drive, any other audio extra front USB ports FireWire don't plug then into motherboard yet, oh and make sure u plug ur fans in , win 7 has universal drivers for VGA port so u should be able to boot up and download drivers or if it came with cd for your motherboard after installed u should be able to plug all other things like front USB ports to your motherboard.
 

Roelfk7

Reputable
Sep 23, 2014
2
0
4,510
0
After replacing mboard on windows 7 pc will not boot into windows

But I thought id share my experience incase anyone else is looking for a solution to this issue,
1. get a Hirens boot cd
2. boot into the mini xp Provided on Hirens
3.
In the hirens utilities, Find registry tools, and click on FIX hdd controller
It launches a dos window, where you select your target root, and choose repair.
It seems to delete the old driver out of current control set 00 from your registry, and replace it with generic version.
Worked like a charm for me!
 

dANb0JtE

Reputable
Oct 29, 2014
1
0
4,510
0

Thank you very much. I couldn't find it on UBCD, but HBCD has been used.
 

michaelzehr

Distinguished
Sep 18, 2008
58
0
18,640
1
The suggestion to use dism was very helpful for me after I replaced the motherboard and cpu on my old computer.

Some additional information for anyone who finds this thread:

There's also a tool called sysprep that generalizes an operating system in preparation for moving it. I think it removes all but the generic drivers that come with a windows install disk. Then when you replace hardware components, you boot up, windows starts finding drivers, and you can also add drivers from the cd that comes with the motherboard. This would have saved some headache to have done this step first.

I ran dism using the motherboard driver CD. I think it installed many uneeded drivers, but upon booting to windows 7 it worked, though I still reinstalled from the CD and also let windows search for driver updates automatically. Took a bit, but everything works.

I don't think there's a reason why you couldn't install the drivers from the cd first, then replace motherboard, although I suppose this isn't any better than using sysprep.