• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Windows can't detect all RAM

Jun 11, 2020
5
0
10
0
Hi all,

I recently bought a set of Corsair Vengeance LP CML8GX3M2A1600C9 to add to my alreadt existing set of Corsair Vengeance CMZ8GX3M2A1600C9 for a total of 16GB of RAM.
Both sets are 2x(4GB) DDR3 with a clockspeed of 1600Mhz.

When I check my system information i see that Windows can only detect 12GB of RAM.


When I check Task manager source control I see that slot 1 is empty.


When I run HWinfo I see that my motherboard is currently running in Triple channel BUT it can detect all 4 sticks.


When I check system information I see that windows detects only 12GB of fysical RAM, but it does add up the 16GB of the sticks to the 4GB of Vram from my GPU for a total of 20GB of Virtual memory.


My specs are:
CPU: Intel I7-3820
GPU: GTX 680 Classified 4GB Vram
Motherboard: Rampage IV Formula (has the latest BIOS version of 5001)
PSU: Antec 900W

I also tried both sets seperately in dual channel and then Windows and HWinfo detects them as 8GB, so the sticks are not defect.
And I also tried the 4 sticks in all possible configurations.

Who can help me so Windows detects all 4 sticks?

PS. I'm dutch, which is also the language you see in the images. But I think most of you will be able to understand the relevant data of the images.
If any more information is needed feel free to ask.
 
Jun 11, 2020
5
0
10
0
did you test 2 stick on all 4 slot?
I just tried, and I have found that when I runs dual channel (1-3) Window and HWinfo can detect the 8GB fine.
But when i run dual channel (2-4) Windows can only detect 4GB but HWinfo detects 8GB. Also at (2-4) dual channel Windows detected 4GB of phsyical RAM but 13GB of Vram was available.





Now I placed all 4 sticks back and HWinfo detects quad channel but Windows can still only detect 12GB.

 
Jun 11, 2020
5
0
10
0
Ok so I just tried 2 and 4 single channel and the PC did't boot when on single channel 4. So it would seem slot 4 is faulty.

But what I don't understand is how HWinfo can still detect the RAM in slot 4 when run in dual channel and quad channel.
 
Jun 11, 2020
5
0
10
0
Little update,

I just ran Memtest and it can detect all 4 sticks but it shows only 12GB of physical RAM is used.






Windows still detects only 12GB and HWinfo still detects 16GB Quad channel...
 
Jun 11, 2020
5
0
10
0
I just did a CPU reseat and cleaned the socket with compressed air. As far as I could tell there were no bent or misaligned pins.
Unfortunately the reseat didn't show any improvements.
 

ASK THE COMMUNITY

TRENDING THREADS