Windows desktop lag/stuttering caused by Aero's "Desktop Composition" (980 ti, 6700k) **SOLVED**

Horrible

Reputable
May 17, 2015
13
0
4,510
0
SOLVED!! (5/21/17)

I came back to this thread because I once again am trying to find the solution to this problem, and finally have figured it out. I noticed lots of other people posted since I made this thread who are having the save problem. It has to do with Asus's "Sonic Suite" software. I'll show the steps I did to fix it.

Steps to fix..

Open msconfig


Click the "Startup" tab


Uncheck "SS2UILauncher" and "SVLoadSense"


Restart

Now, Aero should stop lagging!



EDIT3: The problem is caused by Aero's "Desktop Composition" option! Why?!?! The only solution to this as of now is to disable this feature, which basically disables aero.

The problem I have just begun to experience today is a laggy desktop. When I drag on the desktop, drag windows, open new windows, etc.. I see pretty severe stuttering, however not the mouse cursor. I also get the message "Windows has detected your computer's performance is slow".

All of my hardware is at stock clock and settings. When I play a game, I don't have any performance problems, the problem is isolated to the desktop. I have tried ccleaner and quick scans with BitDefender anti-virus but neither have any effect.

In task manager my CPU usage is < 15% when idle, physical memory < 35%, and 0% GPU usage with 51% power usage.

My idle temps,

CPU - 25c
GPU - 63c (I use prefer maximum performance for power settings, is this high?)

Screenshot of Open Hardware Monitor


Any help would be greatly appreciated!

EDIT: I just now noticed that videos are very laggy as well, but games still run fine. I am running a full system scan now.

EDIT2: I've narrowed the problem down to windows Aero. When I turn off Aero all stuttering goes away, but when I turn it back on it returns!

EDIT3: The problem is caused by Aero's "Desktop Composition" option! Why?!?!
 

Horrible

Reputable
May 17, 2015
13
0
4,510
0
98% used space on the 850 EVOs won't help matters. Are they in a RAID configuration?
They aren't in a RAID configuration. I haven't had much disk space (< 10gb) for a couple weeks, but I will remove some stuff and see if it helps.
 

Horrible

Reputable
May 17, 2015
13
0
4,510
0
Also I noticed using MSI Afterburner hardware monitor that my GPU usage spikes when starting a game, however when I am on the desktop it stays between 0-3%.
 

Horrible

Reputable
May 17, 2015
13
0
4,510
0


I cleared the boot drive to 12 GB and still have lag. I am not sure where the page file is, it is not in the C:\ boot drive directory (I made sure hidden files are shown).
 

Horrible

Reputable
May 17, 2015
13
0
4,510
0


I have windows set to automatically manage paging file size for all drives, and it says

The total paging file size for all drives is 16308 MB.

Oddly though, I don't see a PAGEFILE.SYS under my C: drive with hidden files turned on, even though it says that drive is "System managed" under Paging File Size (MB).

 

Horrible

Reputable
May 17, 2015
13
0
4,510
0
OK I just tried disabling Windows Aero to see if it would help, and the issue of stuttering went away. Why would this be? I tried turning it on again, and the stuttering returns.

EDIT: I should also mention I run a dual monitor setup, one 144hz and the other 60hz.
 

RobCrezz

Polypheme
Ambassador
Are they both running on the same card?

I had weird lag issues running different refresh rates from the same card, I moved my secondary 60hz monitor to run off the integrated graphics instead as it wouldnt play nice running both off my 780 with one monitor at 120hz and the other at 60hz.
 

Horrible

Reputable
May 17, 2015
13
0
4,510
0
I am going to post this over in the Windows 7 section because I feel it's more appropriate there now that I know Aero is the problem.
 

xFelicia

Commendable
Jul 4, 2016
1
0
1,510
0
I have the same problem and we share the same set up (beside the mother board, I have a MSI Z170A M7).
Have you found any sort of solution beside turning off the Windows Aero, since that was the same thing I was doing myself?
I have unistalled Nvidia drivers, reinstalled, tried previous ones, unplugged cables and chagned them, change the monitor frequency, downclocked the 980ti, and so on...nothing worked.
 

Solnfected

Reputable
Jan 9, 2016
30
0
4,530
0
I'm suffering from the same problem, I'm running 5930K on an Asus X99 Deluxe MB and 980Ti. After clean install of Windows 7, everything was fine(Until I installed Windows updates). I was using Aero theme with dual displays just the same way you're(144Hz main and 60Hz secondary display). And just like you did I narrowed the problem down to the Desktop Composition feature, which turns your theme into Windows Basic from Aero just by turning it off.

This is definetely caused by a combination of Desktop Composition and one or more Windows updates, because with my freshly installed Windows 7, before installing any updates, I was using dual displays with all Aero settings enabled, smoothly.

Just wanted to raise a voice and say that it's nothing about any hardware or software related issue other than Windows updates and features themselves. Any kind of help would be appreciated.
 

LadyR3venge

Honorable
Jan 29, 2014
11
0
10,510
0


I've solved just installing Windows 10. Works perfectly now!
 

Solnfected

Reputable
Jan 9, 2016
30
0
4,530
0


Who are you? A paid Microsoft spammer? Windows 10 itself is the problem that I'm still using Windows 7 in late 2016
 

hjfsdhg4g

Commendable
Nov 4, 2016
2
0
1,510
0


I'm not sure if I have the same problem as you; I have a single 144hz monitor and for me the stuttering starts completely randomly but is not constant. I've found that restarting the nvidia drivers fixes it, and also noticed some time ago that simply restarting the DWM service (UxSms) also fixes it. However the simplest "fix" I've found that I've been using for a long time now is to simply wiggle any random window around. I grab a explorer.exe window for example and shake it once: stuttering gone (until it returns usually hours later) but another quick window shake and it's gone again. Maybe this will also work for you? I've tried so many things to try and get rid of this problem it's not even funny and so far this is the simplest solution I've found. Kinda annoying but works.
 

Vtreyus

Honorable
May 9, 2012
2
0
10,510
0
I had same problem it only surfaced when I was running dual monitors tho, disabling desktop composition fixed the laggy window drag and laggy everything, but I really wanted to use Aero. I finally discovered the culprit to be Nahimic 3D sound software that came with MSI motherboard, once I disabled it from starting up with windows, it resolved.
 

ASK THE COMMUNITY

TRENDING THREADS