[SOLVED] Windows Explorer keeping my CPU busy, causing unneeded usage

danny009

Commendable
Apr 11, 2019
203
2
1,595
1
so I have this strange issue since a few years now, windows explorer or any open windows causing my cpu usage from %2 up to %6 which keeps the cpu temps at certain numbers all the time unless I close the all open windows, I use Task Manager to keep track of my network usage and this freaks me out since I'm a detail freak. Is there any way to stop this from happening? I own a Windows 10 1903 if that helps. I did read on Google that broken icons or shortcuts on desktop can cause this but I have to have my icons on desktop so I can access them easier, plus there is no missing shortcut icon on my desktop. Sadly though I lost that website afterwards so I do not have directions,

can anyone help? Windows Explorer and Task Manager really shouldn't use the cpu all the time since I do not interact with them, they just open and minimized,
 
Windows 10 is always working in the background.
plus any motherboard control software and many other applications can be constantly running tasks in the background.
even with all possible processes stopped, zero folders open, and no Task Manager there is still minimal usage going on.

Task Manager will be constantly monitoring system usage and performance stats so as long as it is open the usage will spike higher.

2-6% overall usage is nothing.
if this is causing higher temperatures than you need to work on your cooling solution.
 
Windows 10 is always working in the background.
plus any motherboard control software and many other applications can be constantly running tasks in the background.
even with all possible processes stopped, zero folders open, and no Task Manager there is still minimal usage going on.

Task Manager will be constantly monitoring system usage and performance stats so as long as it is open the usage will spike higher.

2-6% overall usage is nothing.
if this is causing higher temperatures than you need to work on your cooling solution.
 

Bob.B

Commendable
Feb 8, 2021
1,579
196
1,490
26
so I have this strange issue since a few years now, windows explorer or any open windows causing my cpu usage from %2 up to %6 which keeps the cpu temps at certain numbers all the time unless I close the all open windows, I use Task Manager to keep track of my network usage and this freaks me out since I'm a detail freak. Is there any way to stop this from happening? I own a Windows 10 1903 if that helps. I did read on Google that broken icons or shortcuts on desktop can cause this but I have to have my icons on desktop so I can access them easier, plus there is no missing shortcut icon on my desktop. Sadly though I lost that website afterwards so I do not have directions,

can anyone help? Windows Explorer and Task Manager really shouldn't use the cpu all the time since I do not interact with them, they just open and minimized,
WAG....boot the machine and open task manager.
Watch the cpu usage it will take a few mins but it should settle at 0%.
 

Colif

Win 10 Master
Moderator
why are you on 1903? You are 2 years behind now.

The last 3 versions of win 10 were bug fixes, you might be missing some useful features there.

As said, the usage is almost nothing, windows is never not doing something and if it finds you aren't doing anything, it will run background tasks to speed up processes for when you do need them. if you let it idle long enough it will run out of background tasks. And then sit and do nothing. Usage of both those files on my pc right now is below 1%.

Windows Explorer is file manager/desktop so you do use it all the time, just not in a way that is obvious.

Is there any way to stop this from happening?
Sure, turn the PC off :D

I assume that isn't answer you were after.
 

danny009

Commendable
Apr 11, 2019
203
2
1,595
1
Hey sorry for late reply, it seems like HWinfo and MSI afterburner was the source of the problem. Like you said they track and refresh for like every 3 seconds so thats causing the problem. But they are vital to me especially in games so I will ignore from now on the cpu usage.

problem solved, I mark a reply above as problem solved
 

Colif

Win 10 Master
Moderator
hwinfo uses 1% of my cpu all the time, its pay off for the monitoring. You have to balance which is more useful I guess.

I changed its polling rate (HWinfo) to every .500 so its way more accurate as well. I don't notice 1% really.
 

ASK THE COMMUNITY