Question Windows not Detecting Samsung 970 EVO Plus M.2 NVME SSD

Dec 4, 2019
2
0
10
0
System Information:
OS: Windows 10 Pro x64
Motherboard: Gigabyte X570 Aorus I Pro WiFi
BIOS: F10 (came with F3)
SSD: Samsung 970 EVO Plus 1TB

Hello everyone,

I am having trouble getting Windows to detect my SSD. I am in a very similar situation as the OP of this thread, and tried many of the same solutions to no success.

In BIOS, I can see "Samsung SSD 970 EVO Plus 1TB" listed under "M.2" installed in M2A. It's available as a boot option as well. It even passes device self test under the NVMe Configuration section of BIOS. While on another drive with Windows installed, I can see the drive listed in Device Manager, although I get an error message when I try to populate the volume information. It´s just not seen anywhere in Disk Management, or during the installation of Windows 10, or anywhere else, including Samsung Magician.

Some solutions that I tried from the thread:
-Upgraded BIOS to last version
-Sata Mode is AHCI
-Tried to install Windows 10 from 2 different USB sticks
-Tried commands in Windows Installer cmd like fixmbr, fixboot, diskpart etc. to fix errors or detect the drive
-Reseted CMOS battery
-Uninstalled the SSD from the Device Manager
-Ran Samsung's exe which contained the SSD's latest driver version.
-Tried to load the driver by clicking the "Load Drivers" option in Windows Installer.
-Used Samsung's software "Samsung Magician"

I installed the latest drivers from Gigabyte and also ran Windows Update.

I tried following what Calvin suggested:
I disconnected all my other drives
I disabled CSM (which also removed the SSD from the available boot options)
I cleared the secure keys from secure boot (my motherboard doesn't seem to have an explicit option of Other OS vs Windows UEFI)
I installed the factory keys

Is there something that haven't tried that may solve the issue of BIOS detecting the drive, but not most of Windows?
 

popatim

Titan
Moderator
Did this drive already have or previously have an OS on it?

Some motherboards UEFI, being a more secure bios, will block access to a drive that IT didn't put the OS on. Often you can get around this by disabling Secure boot in said bios.
 
Dec 4, 2019
2
0
10
0
Did this drive already have or previously have an OS on it?

Some motherboards UEFI, being a more secure bios, will block access to a drive that IT didn't put the OS on. Often you can get around this by disabling Secure boot in said bios.
The drive did not have an OS on it.

I tried the disabling secure boot option, but in order to do that, I have to turn off CSM, and that removes the drive from appearing in BIOS. In any case, I tried again, but the drive was still not in the list during Windows installation.
 

ASK THE COMMUNITY

TRENDING THREADS