Wireless Xbox One controller issue on Windows 7 PC


Mar 17, 2017
Just recently resurrected an old build I had and was setting it up to play some games on it. My issue is that after installing the Xbox One wireless controller driver (the USB dongle version, controller is also the first model from the launch Xbox One) i’ll turn it on and it seems to work but It varies from game to game. Basically what happens is it’ll just randomly drop its connection to the dongle and it tries to reconnect but it just keeps flashing until I disconnect the dongle from the PC and reconnect it.

For example I can play GTA V and it’ll be fine for 15-20 minutes and then it’ll disconnect and not reconnect until I unplug it. Skyrim (32-bit version) this one I can’t get it to stay connected for even 15 seconds. I’ve scoured on the Internet everywhere and cannot seem to find a solution. It works 100% fine on my laptop (Which is Windows 7) and my primary desktop (Which is Windows 10 version 1803) and does not suffer from the same issues of it disconnecting.

Affected PC specs:
CPU: Intel Core 2 Extreme QX9650 @ 4GHz
MB: Evga nforce 790i Ultra SLI
RAM: Patriot DDR3 1600MHz 2 x 4GB
SSD: Kingston A400 120GB SATA III
SSD: Crucial MX100 512GB SATA III
GPU: 2 x Nvidia GTX 660 in SLI
PSU: Thermaltake White 600W
OS: Windows 7 Ultimate SP1 64-bit (all up to date)
All USB 2.0 ports are functional

Main Desktop it works on:
CPU: Intel Core i7-5775C @ 4.4GHz
MB: ASUS Z97-E/USB 3.1
RAM: Corsair Vengeance DDR3 2 x 8GB @ 2000MHz
SSD: Samsung 850 Evo 120GB
HDD: Seagate Barracuda 7200RPM 2TB
GPU: AMD R9 290X 4GB
PSU: Corsair RM850W Gold
OS: Windows 10 Pro 64-bit (ver 1803)
Worked in USB 2.0/3.0 and 3.1 ports

Laptop it works in:
CPU: Intel Pentium 2020M @ 2.4GHz (Ivy Bridge Mobile)
MB: Toshiba
RAM: Crucial 2 x 8GB 1600MHz
OS: Windows 7 Professional SP1 64-bit (Up to date as far as I know)
Worked in a USB 2.0 port

Steps taken to try and fix it:

1. Reinstalling Windows (did not work)
2. Reinstalled the driver about 20 times now (did not work)
3. Tested the device on two other computers (worked on both of those)
4. Tried other devices in the USB ports of the affected PC (USB ports fully work)
5. Tried a wired connection (Works but not in any game)
6. GeForce Experience is not installed (I have heard conflicting statements on this affecting it and at the same time it doesn’t for other people)
7. Tried it in all USB ports on the motherboard and it does the same exact thing.
8. Computer is not too ancient as it worked in the previous incarnation of this same exact build minus the SLI, with an AsRock G41 motherboard.
9. Setting USB to not turn off to save power (did not work)
10. Updated the controller firmware on windows 10 (did not work)

If anyone has anything else I can try please suggest it because I have been pulling my hair out for a week trying to figure why it will not work in this computer.

Similar threads