Question XFX RX580 GTS Black Edition compability issues.

Nov 23, 2019
33
0
30
0
I have GPU in a new mobo (Asrock X570 Phamtom Gaming 4 with and RAM is G.Skill Aegis 16GB (2x8gb) DDR4 3200.
CPU Ryzen 7 2700
PSU EVGA SuoerNova 750 G5
SSD Samsung EVO 250GB
I did a clean Win10 install but the gpu stops working when the drivers kick in.
I've tries a few times with the same results. Please help
 

Lutfij

Titan
Moderator
Make sure you're on the latest BIOS update for your motherboard. Also, which drivers are you working with? Manually downloaded them from AMD's support site and installed them in an elevated command? i.e Right click installer>Run as Administrator?
 
Nov 23, 2019
33
0
30
0
Make sure you're on the latest BIOS update for your motherboard. Also, which drivers are you working with? Manually downloaded them from AMD's support site and installed them in an elevated command? i.e Right click installer>Run as Administrator?
The problems start when I install the driver for the Motherboard that includes the VGA driver too. Which driver should I install first?
* Correction the problem starts when Windows10 updates so I have no way to make it work after the GPU drive is updated by Win10. Any advice?
 
Last edited:
Nov 23, 2019
33
0
30
0
Ok.This is what I just did: I reinstalled Win10 and then made the OS not to update drivers automatically. This time I could make Win10 take all the updates and activate the Virtual Licence. Then I installed the AMD Drivers 20.2.2. Ounce the deriver kicked in the problems started. The video just went black and did not returned. I restarted and video came back with vertical lines. Then I installed the AMD Mobo chipset drivers and restart and it seem ok at the moment.
 
Nov 23, 2019
33
0
30
0
The PC autorestarted and then there is no video signal sent to the monitor.
Right now I'm testing with a DVI Monitor. It sends a signal when booting and like 2 minutes after booting but then the video signals falls and does not return until I press reset. Is likre it goes to sleep mode but does not return from pressing a keyboard key.
Might it be a BIOS setting that I'm not doing?
 
Last edited:
Nov 23, 2019
33
0
30
0
The GPU is connected to the PSU using only an 8pin connector. Can someone tell me if what is the optimal way to connect this GPU to the PSU? What about the adapter to use 2 6pin cables to connect it. Is that a better option?
 
Nov 23, 2019
33
0
30
0
Today I was testing the PC at work but now I'm home. I noticed that when the GPU shoots down the keyboard also stops working and also the mouse. What could be the problem?
 
Last edited:
Nov 23, 2019
33
0
30
0
I decided to return the GPU RX580.
I might buy the AsRock RX 5500 Phantom Gaming that is supposed to be completely compatible with my mobo ASRock X570 Phantom Gaming 4. Or should I buy the regular GeForce GTX 1660?
 

ASK THE COMMUNITY

TRENDING THREADS