yukonwxp driver "internal error" on GA-965P-S3


Jan 23, 2007
I have a new PC I assembled that is giving me trouble. Here are the specs:

GA-965P-S3 (F8 firmware)
Core 2 Duo E6400
CORSAIR XMS2 DDR2 800 (PC2 6400) Dual Channel Kit 1GB
ATI Radeon X700 Pro
Western Digital Caviar SE16 WD2500KS SATA 250GB Hard Drive
Pioneer DVD Drive
Windows XP Pro SP2 and OpenSUSE 10.2

The issue I'm having is with the on-board LAN controller. It is a Marvell 8056 Yukon chipset. The system event log is filled with event id 101 errors for the yukonwxp driver. The description simply says "Driver has encountered an internal error." And there are always two of them together with the same time stamp. I have tried downloading the latest drivers from the Gigabyte site. I have updated the BIOS, which was at F6, to F8. I ahve uninstalled the device from Device Manager and re-installed it. I am still getting these errors. For the most part the connection still works even though I get the errors. However, my network connection will randomly drop on occasion. Not just the internet connection, but everything on the home network as well. Sometimes it can go for a couple days without dropping, other times less than an hour. However, the connection still shows as connected under Network Connections even when it dies. The dropped connection problem seems to be worse under OpenSUSE.

Seeing as how it is happening under both Windows and Linux I'm apt to think this is a hardware issue, which frustrates me as the first one of these motherboards I got from Newegg.com was DOA. I'd hate to have to return another one. I guess I could just buy a NIC. Any other ideas as to what might be going on?


Oct 9, 2006
I'm with you on this one, it seems like a hardware issue and you've already tried most of the basic solutions available.

A new ethernet card is going to cost what...a few quid/dollars? Why not give it a try, imo it sure beats paying for return postage on an RMA and you dont have to wait weeks either!