Question 1x 144Hz monitor and 2x 60Hz monitor issues


Feb 23, 2006
My setup
Intel i7 8700k
16GB Ram
Asus ROG Strix Z370-F (1802)
Asus ROG Strix GeForce RTX 2080 OC (2x HDMI, 2x Display Port)

24" HP Z24i 60Hz (16:10) - Connected with Display Port
27" Asus PG279Q 144Hz (16:9) - Connected with Display Port
55" Sony TV 60Hz (16:9) Connecetd with HDMI

Windows 10 - All latest updates installed
Latest GeForce drivers
Latest Chrome
Latest Firefox

So my previous problem was with two 24" HP monitors and with their 1920x1200 16:10 native resolutions. Some games didn't like that at all, and it also made my streaming experience really awful. If i streamed, i had to play windowed at 1920x1080 (16:9) so it would scale nicely to 720p. So i was thinking that maybe its time to upgrade to 1440p 144Hz, so i bought ASUS PG279Q monitor. I plugged my new beautiful monitor to display port and enabled 144Hz from display settings. First game i tried was Path of Exile and god it looked good. It was too good to be true, and it was.

So i put my normal setup on. On HP monitor on my left, i have my Discord open and maybe Chrome or Spotify playing some background music. Then i have someones Twitch stream open on my TV muted. And last but not least, i play games on my 144HZ monitor. But you might already quess what happens; all content on 60Hz monitor gets laggy and sluggish. Twitch stream goes sometimes black, sometime sound stutters. If i move volume slider with mouse really fast, it will be rubberband, If i change my 144Hz monitor to 120Hz, it doesn't fix that. If i change it to 60z, everything works smooth. If don't use Chrome but i use Firefox, it does the same thing.

I have Googled about this problem and i have seen all kinds of workarounds. People have been fixing this by enabling iGPU and plugging second monitor to there. Yeah i can do that. But when i stream, i keep my OBS, OBS alerts and chat on my seconds monitor. So what will happen when i have OBS open on my second monitor on iGPU and i try to stream content from 144Hz monitor that is on 2080RTX?

Is there something that i have missing or something i could try?


Mar 13, 2017
If there is an option in geforce experience like multimonitor power saver enabled, try to disabled. Make sure your two 60 hz monitors are indeed set at 60 hz and not like one of them is set at 59 hz. If no luck just try to share the load to the igpu for any extra content currently sent over the 55" tv.