Question 3600MHz DDR4 RAM can't run at rated speed [SOLVED]

Jan 23, 2023

I bought a Kingston Fury Beast 16GBx2 kit of DDR4 3600MHz CL18 and installing it on ASRock H670 PG Riptide & i5 12400F
The motherboard specification says that it can support up to 5000MHz of memory speed.

At first the memory was running on 'Auto' and I'm getting 2400MHz, I looked at the XMP profile that came with the RAM and it got:
XMP profile 1 : 3000 MHz 16-18-18-36 @ 1.35V
XMP profile 2 : 3600 MHz 18-22-22-39 @ 1.35V

When I set it to Profile 1 it run just fine.
But with Profile 2, my PC got BSOD (IRQL_NOT_LESS_OR_EQUAL) in less than 30 mins of use. Unless I just turn on the PC and leave it doing nothing.
Playing games crash it, installing program also crash it. Anything that start using a little more RAM crash my PC to BSOD

I tested it with OCCT @ 80% memory, and start seeing errors within 10 sec of running profile 2

If I use Profile 2 I will get errors and BSOD
If I tried with 3600 MHz 18-22-22-39 @ 1.4V/1.45V/1.5V I will also get errors and BSOD

I was able to run without errors with Profile 1
Then I tried to set it manually and was able to run without error with 3200MHz 16-18-18-36 @ 1.35V

Since I bought a RAM rated for 3600MHz, and installed it on a motherboard that support way more than that.
At least I was expecting it to run at the speed it was rated for.
Even one of the XMP profile provided by the manufacturer doesn't work.

So right now my only solution is letting it be a 3200MHz CL16 RAM.
But is there a way for me to get this to run at 3600MHz?
Intel reports that this processor supports memory types rated up to DDR4 3200 MT/s.
while Kingston reports these DDR4 kits at 3733 MT/s.

so running this lower valued XMP Profile 1 could explain why the kit then functions.

i imagine figuring out what exact values(MHz/CL/etc) with this kit = 3200 MT/s would be your goal now to get this kit to function properly.
then raise values slightly from there to find the "sweet spot" this CPU may accept.

or just get a kit that is already rated as acceptable.
  • Like
Reactions: NattWara
3200 speed is what the 12400F can run at:

Not to worry, your real app performance is not much impacted by ram speed. Think 1-2%.

3600 speed ram is just well binned 2400 speed ram that can overclock to a higher speed. It will run just fine at 3200.
To verify.
Run memtest86 or memtest86+
They boot from a usb stick and do not use windows.
You can download them here:
If you can run a full pass with NO errors, your ram should be ok.

Running several more passes will sometimes uncover an issue, but it takes more time.
Probably not worth it unless you really suspect a ram issue.
  • Like
Reactions: NattWara
Jan 23, 2023


Ok, will try the memtest86

By the way, I checked the i9 12900 at
It also said support speed up to 3200 DDR4

Also Threadripper 3990X

And ryzen 9 5950x

So why is there a DDR4 RAM labeled 3600 speed on the market?
If even all these high-end CPU doesn't support it.

"Support" means different things when manufacturers use it. In some contexts it means what it can support at stock, some with overclocks, and some what it can run, period.

You can in fact run the Zen 3 processors with 3600 MHz memory quite easily. In fact, that's considered the sweet spot for Zen 3. However, Ryzen processors are more sensitive to RAM speed than Intel ones simply because of the way they're designed.
  • Like
Reactions: NattWara
Jan 23, 2023
Thanks the help guys. I finally get it working now. :)

So it look like my Motherboard is using too old version of bios. About 7-8 version from the latest.
I updated it from 4.01 to 11.05 (latest one on Asrock website) and now it can use the 3600 XMP.

I still didn't dig deep how to get the memtest going.
But the OCCT is not showing any error anymore.
Also tested by gaming for around 3-4 hours and it doesn't crash anymore.

By the way, now the setting say 100:18:2
I think the 100 is ref clock and 18 is multiplier. But what does 2 mean?

Before updating the bios and I use 3000 XMP profile, it was 100:30:1
  • Like
Reactions: JohnBonhamsGhost
Apr 23, 2023
I updated my BIOS (only had one version shy of the most recent one) and now with DOCP profile it "passes" the first test and immmediatly shuts down and reboots itself, then it reboots normal. Everytime i "reboot" it does that....:/ even worse now xD
Also iCUE stoped reconizing the RAms, dont evne apply the lighting setup it had (all white). It doesnt appear on the list :/ Tried DOCP aswell on frequency 3200, but doesnt appear on iCUE either.