Question An operating system wasn't found. Try disconnecting .....

Dec 31, 2020
Hi, I have this new problem at my motherboard, this motherboard the Intel DH87MC have 4 SCSI ports. All ports have disks and in one port I have an SSD Samsung 500GB) working normally like the others 3 HDD. The problem rises when I changed SSC port to no.1. PC wasn't booting and black screen with "An operating system wasn't found. try disconnecting any drivesthat contain an operating system." This happened when changed the SSD to no.1 port.
Then I tried all combinations of the ports, but no luck.- the same error.
All the 4 drives are installed with windows 10. and all the four are shown in the bios.
Mine is multi-boot system using EasyBcd.
When the SSD is connected back to port 4 the system is booting.
I am unable to understand why the system is not booting when SSD is connected to other ports. No success even when the SSD is changed to no.1 in bios boot options.


Do you mean SATA instead of SCSI?

Motherboard User Manual:

Verify that I identified the applicable User Manual.

Reference Section 3.8.4 (physically numbered Page 68) to verify the boot options.

Take a close look at the SATA ports and their respective labels. Should be SATA(0) to SATA(4) for a total of 5 SATA ports.

Also see the Note on the bottom of Page 69.

Overall if a given configuration works, i.e., SSD in SATA(4) then just stay with that configuration even if the "numbering" is not as you would expect.

Even though the natural sense may be that the SSD "should be" in SATA(0) or even SATA(1) ...