[SOLVED] ASrock RX590 crashing under load

Status
Not open for further replies.

Cthulhuism

Reputable
Dec 8, 2015
8
0
4,510
0
barely got a rx 590 today and was excited to run userbenchmark on it, booted the app up and as soon as the actual benchmarks start happening it crashes, same place again and again, same with games after a while, and as soon as i run a gpu stress test on furmark, been running stabily for a while on browser lol

CPU is I7-4770
GPU i had before was a zotac 1060 6gb
PSU is 500w FSP500-50AAGA (might be the problem)
mobo Acer Predator G3-605 (LGA1150)
ram 12.0GB Dual-Channel DDR3 @ 798MHz
1863GB Seagate ST2000DM001-1CH164 (SATA )
111GB TEAML5Lite3D120G (SATA (SSD))

if you need anymore information let me know, Thank you
 

Phillip Corcoran

Titan
Moderator


Very likely since RX 590 has higher power requirements (especially when stress-tested) than your 1060, yet your using the same PSU. And in any case, no way to know for sure until you replace it with a better one.

 
Reactions: Aggelos Gedeon

Cthulhuism

Reputable
Dec 8, 2015
8
0
4,510
0


how likely is that the problem? i dont want to get one if i dont have to
 

Phillip Corcoran

Titan
Moderator


Very likely since RX 590 has higher power requirements (especially when stress-tested) than your 1060, yet your using the same PSU. And in any case, no way to know for sure until you replace it with a better one.

 
Reactions: Aggelos Gedeon
I had an RX 590 and returned it and got a Vega 56 instead. I think that the 590 was something like a 225 watt card. You figure that's almost half the load of your PSU right there. And that's not even knowing how good your PSU really is. I'd replace that first off and see what happens.
 
Dec 4, 2019
1
0
10
0
I have the exact same issue exept I have a 650W psu with 80+ and I don't want to wait until the seller sends it over to ASrock in order for it to be checked and they also want to charge me all shipping costs +20€ (roughly 22.20$US) if they don't find a problem. What do you guys suggest? Also @Cthulhuism did swapping psu's solve your problem?
 

Phillip Corcoran

Titan
Moderator
I have the exact same issue exept I have a 650W psu with 80+ and I don't want to wait until the seller sends it over to ASrock in order for it to be checked and they also want to charge me all shipping costs +20€ (roughly 22.20$US) if they don't find a problem. What do you guys suggest? Also @Cthulhuism did swapping psu's solve your problem?
Aggelos, this thread is 11 months old! (look at the date, didn't you notice that?).
It's closed now so please start your own thread.
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS