Question [Asus G73sw] No Lan after Bios flash

Jul 28, 2018
2
0
10
0
Hello,

I’ve flashed the BIOS of my Asus G73sw laptop to enable Intel AES-IN. The flashing process was succesfull be done, but after reboot my LAN port stopped working. The LAN card also not showing in ‘Device Manager’. To resolve the problem I tried to re-installing the LAN driver with no luck. During the install process I’ve get the following warning: ‘The Realtek Network Controller was not found. If Deep Sleep Mode is enabled Please Plug the Cable’. I thought the LAN Card died so I bought a new one. After receiving the new LAN Card I installed it to my laptop. Unfortunately this doesn’t resolve the problem. Still no working LAN port and the same error during the driver installation. After some research on the internet I think that the BIOS flash has override the MAC address of my LAN Card. To change the MAC address of my LAN Card to a correct one I found this tutorial: http://www.ocworkbench.com/2002/ecs/k7s5aguide/LAN MAC ADDRESS FIX GUIDE.htm

The problem is that I can’t found the original MAC Adress of my LAN CARD on the sticker of the LAN Card. Can someone help me to find out what the MAC Adress of my LAN Card is so I can change the overridden address to the correct one. See the pictures below for my LAN Card



 
Jul 28, 2018
2
0
10
0
There is no MAC info on that card. Was this BIOS flash done from an official bios from the vendor?

I don't see how the MAC address changing would make the card not detected at all in the system.
My motherboard died so I replaced it. After the replace I did a clean install of Windows and flashed the official Bios with a custom one to enable Intel AES-IN.

The strange thing is that if I replace the card for a new one the problem is still the same.....
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS