Question Asus mobo not powering on

Oct 13, 2021
4
0
10
0
Hi there
First time posting.
I'm facing an issue with my Asus ROG Strix X570-F

Bit of back story:
Two days ago I installed a new mobo, ram and cpu into my desktop.
Initially all was working ( had to run flashback since its a Ryzen 5000 Cpu )
I then Installed windows and noticed the CPU temps were sometimes reaching 80+
So I turned it off and took off the AIO, cleaned the thermal paste off and put it back together making sure to properly seat the AIO
Put pc back together, aaaaand nothing.
No fans, no led, psu not turning on etc.

What I have tried:
Tried changing PSU ( nothing )
Tried using my old mobo and cpu ( works )
Tried running flashback again ( flashback led works and flashback runs and completes ) ( still nothing )
Tried taking out CMOS battery and leaving for 10 minutes ( nothing )
Took out motherboard and psu, unplugged everything except [ 8 pin, and 24 pin, ram, cpu, aio fan header ] ( nothing )

In bios I did disable rbg leds, which in hindsight makes it a bit harder to debug.

Would greatly appreciate any assistance.
Many thanks
 
Oct 13, 2021
4
0
10
0
if its anything like my rig then there should be two pins at the front on mine page 1.9 and screwdriver across WITH POWER DISCONECTED FIRST CLEAR RTC it did work for me when I had too.
I do also have the two pins to clear rtc

also tried that, what are the steps to do so?

disconnect power
plug in jumper or bridge two pins
wait 10-15 seconds
plug in power
and turn on?

if that is correct steps, sadly I have tried this
 
That is the correct procedure of doing that
I do not know of anything else too sugest unfortunatly
I would of said that I held the screwdriver on there for a good minute too make sure with power off but that was just me making sure.
 
Last edited:

ASK THE COMMUNITY