Question Asus PRIME A320M-K won't turn on

Sep 27, 2020
2
0
10
0
Hello guys, I've been using this PC for about 16 months, one day it just won't turn on. No beep, no video, no fan spins, no HDD noise. I tried 3 PSU that I checked they work in other systems. Remove the Rams and fans. Bridge the power pins in case the chassis power bottom is broken. The orange lights (in the MOBO) stay flashing or stay on when I plug the power cord (I do it several times, the lights behavior it seems random), even tried different power cords. I checked the MOBO but didn't see any burn marks. Removed the battery for about 2 minutes and nothing. Some times when I turn on the PSU I hear a low Buzz, but may be just my imagination.

Ryzen 3 2200g
Asus PRIME A230M-K
Kingston Value Ram DDR4 4gb 2666mhz Kvr26n19s6/4 (x2)
Seagate Barracuda 2000GB
Cooler Master EXTREME POWER PLUS 500w
Cooler Master Masterbox Q300l
Cooler Master Hyper 212 Led Rr-212l-16pr-r1
 

egda23

Prominent
Jun 14, 2020
561
101
640
20
Hello guys, I've been using this PC for about 16 months, one day it just won't turn on. No beep, no video, no fan spins, no HDD noise. I tried 3 PSU that I checked they work in other systems. Remove the Rams and fans. Bridge the power pins in case the chassis power bottom is broken. The orange lights (in the MOBO) stay flashing or stay on when I plug the power cord (I do it several times, the lights behavior it seems random), even tried different power cords. I checked the MOBO but didn't see any burn marks. Removed the battery for about 2 minutes and nothing. Some times when I turn on the PSU I hear a low Buzz, but may be just my imagination.

Ryzen 3 2200g
Asus PRIME A230M-K
Kingston Value Ram DDR4 4gb 2666mhz Kvr26n19s6/4 (x2)
Seagate Barracuda 2000GB
Cooler Master EXTREME POWER PLUS 500w
Cooler Master Masterbox Q300l
Cooler Master Hyper 212 Led Rr-212l-16pr-r1
Last thing is disconnecting the HDD, and try. If no change, either the mobo or the CPU is dead
 
Sep 27, 2020
2
0
10
0
Last thing is disconnecting the HDD, and try. If no change, either the mobo or the CPU is dead
Yea, forgot to write it, tried that too, just the CPU with and without fans, MOBO power cords with and without CPU power cord, orange lights still flashing and no other signs of activity
 

ASK THE COMMUNITY

TRENDING THREADS