Question Asus R9 270 driver installation error

Feb 11, 2019
4
0
10
0
Hello, i bought this card back in may 2018 (used and opened to put new thermal pasta) and it worked until january 21st when driver 19.1 arrived from AMD and after installation, windows logo would show up and then black screen. I tried to install 18.12 driver but it didnt work also. My configuration is Windows 10 64bit, Athlon X4 840 processor, 2x4gb ddr3 ram memory, Asus A68hm-k. I even tried to install drivers when i returned to Windows 7 64bit but it didnt work. Is the graphics processor problem or bad memory maybe? What should i do? Now i use HD 6450 and its working perfectly. Maybe my mistake was that i didnt test the R9 270 but i have been playing Gta V, Ac IV, Rogue and Unity and it worked fine. Rarely, it would kick me out of AC Rogue but i dont consider it a problem. After installing Windows 10 64bit with HD 6450 and putting R9 270 back, windows 10 was really slowed down. I even used DDU but it didnt work while on windows 7. The coolers do work but when i enter safe mode and remove R9's driver then after reboot into normal mode, it would get VGA display driver automatically and work like that.
 
Feb 11, 2019
4
0
10
0
19.0.1 or 19.1.0 for like 2 days then when i ran Gta V it didnt load textures and game froze and red lines appeared on monitor and when i restarted windows, black screen appeared. Now some new drivers came up promising that black screen is fixed. Shall i try installing it?
 
Feb 11, 2019
4
0
10
0
On my father's PC it didnt even want to show anything at all while GT9600 did show a picture. But on his PC there were no drivers for R9 270.
 

ASK THE COMMUNITY