[SOLVED] Asus ROG Strix B450-F // Orange DRAM light error - No Display Recognition

Page 2 - Seeking answers? Join the Tom's Hardware community: where nearly two million members share solutions and discuss the latest tech.

Koushal Saini

Honorable
Oct 19, 2014
230
2
10,685
0
No you need an older AMD CPU to install so you can flash the BIOS.
Read my earlier post for options to do that.
Thanks, i thought i can boot without cpu and install bios but was wrong..... I had contacted local vendor abt this and ill have the issue solved.


Thanks a lot man for quick replies and solving my problem.


Just for knowledge i wanna know why its showing orange led not red for cpu?
 

Koushal Saini

Honorable
Oct 19, 2014
230
2
10,685
0
My rog logo (on io shield) is not glowing after the update do u know abt this???


How do i set the ram to 3200mhz and the ram which we have selected are made to run at 3200 right??
 

DMAN999

Reputable
Herald
My rog logo (on io shield) is not glowing after the update do u know abt this???
Yes, I have seen a post or two about that issue.
I wouldn't worry about it for now.
I'm sure they will fix it in a new BIOS at some point.
As long as the system is working properly I would be happy.
I t may take a few BIOS revisions before they get all the bugs worked out.

How do i set the ram to 3200mhz and the ram which we have selected are made to run at 3200 right??
Go into the BIOS and select DOCP Standard for the AI Overclock Tuner setting then select the 3200 MHz DOCP profile and set Memory Frequency to 3200 MHz if it doesn't do that automatically.
Here is a pic of mine running at 3400 MHz (it took quite a while to get it to work at that speed so leave yours at 3200)
View: https://imgur.com/gzTBd7t
 
Last edited:

Koushal Saini

Honorable
Oct 19, 2014
230
2
10,685
0
Yes, I have seen a post or two about that issue.
I wouldn't worry about it for now.
I'm sure they will fix it in a new BIOS at some point.
As long as the system is working properly I would be happy.
I t may take a few BIOS revisions before they get all the bugs worked out.


Go into the BIOS and select DOCP Standard for the AI Overclock Tuner setting then select the 3200 MHz DOCP profile and set Memory Frequency to 3200 MHz if it doesn't do that automatically.
Here is a pic of mine running at 3400 MHz (it took quite a while to get it to work at that speed so leave yours at 3200)
View: https://imgur.com/gzTBd7t
Thanks man!!
 
Dec 11, 2019
4
2
15
0
Hey guys Im having pretty much the same exact issue. Im using a ryzen 5 2600x and the Asus ROG Strix B450-F mobo, with 2 16 GB corsair vengence pro 3200 DDR4 ram. and when i boot up the yellow light is on indicating there is an issue with the ram. also nothing is displayed on the monitor when i plug into the graphics card. everything including the graphics card and the case rgb light up except the ram. I tried switching the sticks and using one at a time.
  • PSU - Cooler master 750W fully modular
  • CPU - AMD RYZEN 5 2600x
  • GPU - MSI GeForce RTX 2070 SUPER 8 GB GAMING X Video Card
  • MOBO - ASUS ROG STRIX B450-F GAMING AM4
  • RAM - Corsair Vengeance RGB Pro 32 GB (2 x 16 GB) DDR4-3200 Memory
  • SSD - Intel 660p Series 1.02 TB M.2-2280 NVME Solid State Drive
  • Cooling - stock amd wraith spire
  • OS - Windows 10 pro eventually once it boots or even gets past POST
  • Case - Antec nx310 mid tower case
 

throwawayaccnt

Reputable
Apr 20, 2016
102
10
4,595
4
Hey guys Im having pretty much the same exact issue. Im using a ryzen 5 2600x and the Asus ROG Strix B450-F mobo, with 2 16 GB corsair vengence pro 3200 DDR4 ram. and when i boot up the yellow light is on indicating there is an issue with the ram. also nothing is displayed on the monitor when i plug into the graphics card. everything including the graphics card and the case rgb light up except the ram. I tried switching the sticks and using one at a time.
  • PSU - Cooler master 750W fully modular
  • CPU - AMD RYZEN 5 2600x
  • GPU - MSI GeForce RTX 2070 SUPER 8 GB GAMING X Video Card
  • MOBO - ASUS ROG STRIX B450-F GAMING AM4
  • RAM - Corsair Vengeance RGB Pro 32 GB (2 x 16 GB) DDR4-3200 Memory
  • SSD - Intel 660p Series 1.02 TB M.2-2280 NVME Solid State Drive
  • Cooling - stock amd wraith spire
  • OS - Windows 10 pro eventually once it boots or even gets past POST
  • Case - Antec nx310 mid tower case
Are you able to test the RAM in another system to eliminate that source of error? If you are able to test other RAM and you're still getting that obnoxious light I'd suggest RMA.

Out of curiosity was your first motherboard factory wrapped/sealed when it arrived? Mine was not and it sketched me out, low and behold it didn't work and I sent it back to NewEgg lol
 
Dec 11, 2019
4
2
15
0
I was thinking of calling my local computer repair shops to see if they ave spare components they can use to test my pc to see which is the source of error and then getting that replaced. and my motherboard was sealed in the antistatic plasitic in the box but the box itself was not sealed with any type of tape.
 
Last edited:

throwawayaccnt

Reputable
Apr 20, 2016
102
10
4,595
4
I was thinking of calling my local computer repair shops to see if they ave spare components they can use to test my pc to see which is the source of error and then getting that replaced. and my motherboard was sealed in the antistatic plasitic in the box but the box itself was not sealed with any type of tape.
Alternatively to paying the labor cost for a repair shop, are you able to purchase a plugin BIOS speaker? Should give you the error code on bootup and you'll be able to tell what's causing it
 
Dec 11, 2019
4
2
15
0
that was something i was looking into but it will take a while before i can get it since i dont think any stores near me sells it so i might have to order it. and the shop near me usually wont charge me if i jsut have them see what the problem is and not fix it but ill order it and see if they will look into it, if not then ill have the speaker

Also i noticed this after my first post but the mouse doesn't seem to be powering on. ive hooked up the keyboard and it turns on (I can tell because both the keyboard and mouse have rgb lighting). the mouse works fine when i hook it up to my laptop. idk if its cause the pc hasnt even got to the post screen or because i dont have os right now. its my first build.
 

ASK THE COMMUNITY

TRENDING THREADS