Question Asus Sabertooth Z97 Mark1/3.1 (Bios Update not working for NVME)

luzhun

Honorable
Nov 21, 2013
84
1
10,645
1
Hello all. I have an Asus Sabertooth Z97 Mark1/USB3.1 Motherboard and am trying to update it to the latest BIOS to see if that may help with making the M.2 NVME drive to finally work.

Current BIOS version is from 2015 (2801) and the latest is: 3503

With Asus, the files are called CAP files and supposedly has an "EZ Flash" option which I tried using.

I bought a 1TB Samsung 970 EVO Plus NVMe M.2 V-NAND SSD and 2 different M.2 PCIe x16 adapters for it, in case the original did not work, but I found that the BIOS did detect the new drive, so the drive and original adapter card is working for sure.

The current BIOS version must be new enough to accept and recognize M.2 drives since it is detected and has some sort of NVME setting listed within the BIOS, but would be nice to still have the latest available. I downloaded the latest BIOS version and extracted it to the root location of a FAT32 USB Flash Drive.

I used a brand new 16GB Sandisk Cruzer Glide USB stick, if you want to confirm that it is FAT32 for sure? Could this be the model number for it? SDCZ60-016G-AW461

Upon going to the Tool tab within the BIOS, I select the firmware update option, see the drive and file, but when I tell it to "read" the .CAP file, it says that it is not a "Valid" BIOS version and does nothing.

View: https://imgur.com/a/c2WhdFx


----------------------------------------------------

If anything, I am wondering if there is a BIOS setting somewhere that is not allowing for the M.2 drive to work or even be bootable? Windows is not seeing the drive, even as a secondary option. It is not showing up in Windows at all. When I turn on Intel Rapid Storage Technology in BIOS, I get a blue screen error message that I have a screenshot of.

View: https://imgur.com/a/CC6fRnK


Thank you for the help or suggestions on what else to look for within the BIOS and try out.
 

ASK THE COMMUNITY

TRENDING THREADS