Question ASUS X99 Deluxe II does boot from new UEFI installation

May 20, 2019
3
0
10
0
Hi everyone

I bought myself a M2 SSD Samsung 970 PRO 1TB and I tried to install Windows 10 on it. Easy, I thought. I plugged the SSD into the M2 Port and it shows up in BIOS. I created a bootable USB Stick with Windows Media Creation Tool, then disconnected all other harddrives and SSDs. I bootet from the USB Stick and the Windows installation completes just fine. When the system tries to restart, it's not able to boot from the M2 SSD. Boot Override won't work either. The screen gets dark and I see some dashes flashing in the left top corner before it returns to BIOS again.

My old Samsung 850 1TB SSD (with windows 10 installed in legacy mode) still boots perfectly. In Disk Management I can also see the EFI partition on the M2 SSD. I can also use the M2 SSD as a normal storage device.

My system:
Motherboard: ASUS X99 Deluxe II LGA 2011-v3
CPU: Intel Core i7 6850K
Cooling: Corsair H100i v2
RAM: Corsair Vengeance RGB 4x 8GB
GPU: ASUS GTX 980 Ti STRIX GAMING DC3OC
PSU: Corsair AX860
OS: Windows 10

That's what I tried already - without success.
  1. In BIOS I disabled CSM (Compatibility Support Module), set secure boot option to "other OS" instead of "Windows UEFI MODE" and cleared secure boot keys, then tried to install Windows again. As described here: https://forums.tomshardware.com/threads/how-to-properly-install-m-2-into-x99s-sli-plus-motherboard.3403677/
    Same result. When I disable CSM, BIOS won't recognize my old SSD as a bootable drive (which is obvious because it's installed in legacy mode) and my new M2 SSD after the installation (which should show up because I tried to do a UEFI installation). The bootable USB stick on the other hand shows up with CSM disabled with the prefix "UEFI". There is also no "Windows Boot Manager" in the boot menu.
    I also tried different settings in CSM: only UEFI or UEFI first. No change.
  2. I updated BIOS. First to version 1802, no change. Then to the beta version 1902 which I have now. No change. https://www.asus.com/ch-de/Motherboards/X99-DELUXE-II/HelpDesk_Download/
  3. I tried another (SATA) SSD OCZ Vertex3 which already worked perfectly as a (legacy) boot drive in the past (with another motherboard though). I connected it to the same SATA port as the working Samsung 850 Pro. Same result. --> So I reckon the m2 SSD is not dud.
  4. Connected the M2 SSD with the adapter on the PCI slot. No change noticeable.
  5. I created the bootable USB Stick with Rufus and tried different settings (MBR and GPT) and performed the installation with it. No change.
  6. I manually selected the bootable USB stick with the UEFI prefix in BIOS boot menu to start the installation process.
  7. I tried another USB stick and even created a bootable DVD. No change.
  8. Before I started the installation I cleaned the SSD with diskpart "clean" and converted it to GPT or another time to MBR. No change. Windows changes it to GPT, which is correct I think.
  9. I disconnected all USB devices before booting (even keyboard). No change.
  10. After the installation I tried to repair the Windows installation with the bootable USB stick. I get the message that the repairs couldn't be executed.
What am I missing here?

Any help is greatly appreciated.
 
The NVMe M.2 drive should be the only storage drive connected.
It should be empty, no nothing on it.

NVMe SSDs do not appear within the BIOS until Windows creates the system partition with the EFI Boot Sector. Your M.2 SSD contains UEFI driver information within the firmware. By disabling the CSM module Windows will read and utilize the M.2-specific UEFI driver

Go into the bios, under the boot tab there is an option for CSM, make sure it is disabled.

Click on secure boot option below and make sure it is set to other OS, not windows UEFI.

Click on key management and clear secure boot keys.

Insert a USB memory stick with a bootable UEFI USB drive with Windows 10 Setup* on it, USB3 is quicker but USB2 works also. A Windows DVD won’t work unless you’ve created your own UEFI Bootable DVD.

Press F10 to save, exit and reboot.

Windows 10 will now start installing to your NVME drive as it has its own NVME driver built in.

When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that windows boot manager now lists your NVME drive.

Click on secure boot again but now set it to WIndows UEFI mode.

Click on key management and install default secure boot keys

Press F10 to save and exit and windows will finish the install. Once you have Windows up and running, shutdown the PC and reconnect your other SATA drives.
 
May 20, 2019
3
0
10
0
Thank you for your replies!

@alexoiu : So you're suggesting to contact ASUS? I haven't heard good stuff about their support but I'll give it a try.

@Calvin7 : As discribed and linked above I already followed your instructions. It fails after the reboot when BIOS will list neither my M2 SSD nor Windows Boot Manager. With CSM enabled and allowing legacy mode, the M2 SSD shows up but still no Windows Boot Manager. When I try to boot from my M2 SSD it returns to the BIOS immediately.
 

ASK THE COMMUNITY