ATI Radeon x1900xt performance issues

banjax

Distinguished
Aug 24, 2006
5
0
18,510
0
Hi all

I was wondering if anyone here has any suggestions as to why i am getting poor performance with my new x1900xt 512 mb

please see the below screenshots in hitman blood money

On the initial welcome screen , not really much happening 20fps !



Here are all the settings i have set in the options menu .



An ingame screenshot again 20Fps the max i get is about 30fps .



i got 7667 points in 3dmark 2005 .

My Spec

Videocard: ATI X1900XT 512MB
Processor: AMD Athlon64 3200+ 130nm, Newcastle
Mainboard: GigaByte Nforce4 K8NE Socket 754
Memory: DDR 400 1500Mb ( 1 x 1gb 2 x 256mb )
Soundcard: Integrated Sound
PSU: Enermax 650W

I have made sure that the driver for the card is set to application preference for AA and AF .

I am running all the latest drivers for everything .

Any help would be appreciated , as its driving me nuts ..

Cheers
 

GrimReaperGuy

Distinguished
Aug 22, 2006
63
0
18,630
0
Okay, first step would be to disable VSync, you should see an immediate increase in your framerate (although you are likely to now suffer from tearing).
Short of that, I would guess that it's your CPU that's holding you back. I'm not familiar with the Skt748 Athlons, but if they follow the same naming as the Skt939s (I'm guessing they do), that means you're running at 2.0GHz, in which case your CPU shouldn't be a problem, as I'm running a 3000+ (1.8GHz) and am generally getting in-game framerates hovering between 40-50 with a 7800GTX.
Your 3dMark05 score does seem a little bit low for a X1900XT though... I can't really offer any other help, sorry. :(
 

banjax

Distinguished
Aug 24, 2006
5
0
18,510
0
Yep i tried disabling vsync and it made very little difference . It is a 2.2ghz athlon , so i think it should be able to handle what is really a gpu intensive game ?

I dont know , thats why its driving me nuts , i just bought the card ( upgraded from a geforce 6800 ) and expected to see a big leap in performance , and instead see around the same performance ...
 

FeareX

Distinguished
Mar 13, 2006
696
0
18,980
0
Fear is a really intensive game...

You can dowload Fear Combat for free now, wich is the same. But only on line
 

banjax

Distinguished
Aug 24, 2006
5
0
18,510
0
Fear is a really intensive game...

You can dowload Fear Combat for free now, wich is the same. But only on line
I have the original FEAR , havent tried it though with this new card .
 

cusis

Distinguished
Mar 22, 2006
109
0
18,680
0
try taking out the 2x 256 ram and just leaving the 1gb in there, is it in dual channel performance mode on your bios etc? coudl be something to do with bios holding you back? try defraggin your hd, running a window xp cleaning programme like cc clener and running disk keeper 10
 

banjax

Distinguished
Aug 24, 2006
5
0
18,510
0
is there any tool that will allow me to see where the bottleneck is ?

I will try removing the 256mb dimms when i get home .
 

Eurasianman

Distinguished
Jul 20, 2006
883
0
19,010
5
um, Socket 754 doesn't support Dual Channel. I know! LOL My setup is similar to his, except, I'm still using an AGP GeForce 6800. My new computer (read signature) is going to be using an ATI X1900XT though. When I have it up and running, I'll post my 3DMark score for the author of the thread.
 

sojrner

Distinguished
Feb 10, 2006
1,733
0
19,790
1
as others have suggested you need to run other games. This will tell you if it is a game-specific thing or a system thing. Don't go swapping out components until you determine this as it will be useless if it is game-specific.

If runs fine on FEAR and a few other games (ut2004 is a solid benchmark game, also run 3dmark 05 and 06 and post the results) then it is a problem w/ the hitman game. In this case try disabling catalyst AI in the drivers as some games do not like the optimizations. You seem to have the other settings solid, so I would also try reinstalling the game. Beyond that you should try the game dev's support forums to find if there is a patch or fix for the issue.

If it does not run well on other games, then it could be you should reinstall the driver. Make sure all your other drivers are updated as well. (I know you said you have them, but just make sure... I myself forget now and again; windows, mobo, sound etc.) Only after exhausting all those options should you start removing ram. IMO though w/ that socket 754 you should not notice any diff from 1.5 to 1 gig of ram. (all still single channel as euroman pointed out)

I personally suspect a software issue and not a hardware one. Make sure to post the 3dmark results as many of us have not played hitman, but the 3dmark score will be more telling (to me at least ;) ) of what your system is doing. Good luck man.
 

kamiri

Distinguished
Aug 18, 2006
24
0
18,510
0
um, Socket 754 doesn't support Dual Channel. I know! LOL My setup is similar to his, except, I'm still using an AGP GeForce 6800. My new computer (read signature) is going to be using an ATI X1900XT though. When I have it up and running, I'll post my 3DMark score for the author of the thread.
This is an incorrect statement. Maybe your socket 754 motherboard does not support dual channel DDR, but mine does...

http://usa.asus.com/products4.aspx?l1=3&l2=14&l3=66&model=772&modelmenu=1
 

sojrner

Distinguished
Feb 10, 2006
1,733
0
19,790
1
afaik socket 754 procs are all single channel, regardless of what the mobo "supports". Only w/ 939/940 (and newer) did amd have the dual channel controller in the proc that I know of.

look here on wikipedia.

Socket 754 is a budget-minded socket, for use with AMD Athlon 64 or Sempron processors. It differs from Socket 939 in several areas:

* support for a single channel memory controller (64-bits wide) with maximum of 3 DIMMs (no dual channel support)
* lower HyperTransport speed (800 MHz Bi-Directional, 16 bit data path, up and downstream)
* lower effective data bandwidth (9.6 GB/s)
* lower motherboard manufacturing costs
oh, and reading the product page on your mobo, while it says dual channel on the top list, in the details it mentions nothing about it. Things that make you go hmmmm... ;)
 

shawnpaul3

Distinguished
May 31, 2006
125
0
18,680
0
Ditto, eliminate the easier possibilities first. If no success there, then attempt cusis suggestions.

I am disappointed, though, to see the x1900xt 512mb not doing any better than that. That card is my number one choice as soon as I have the budget for a new build. Are the games just developing faster than the graphics cards?
 

desolationw

Distinguished
Aug 4, 2006
396
0
18,810
5
he has 3 slots for memory and has used all three of them right? i heard that if you fill the 3 slots you half the speed of the memory, at least i no this is true with old sdram.

am i right or was i just reading some bullsh*t?
 

sojrner

Distinguished
Feb 10, 2006
1,733
0
19,790
1
Ditto, eliminate the easier possibilities first. If no success there, then attempt cusis suggestions.

I am disappointed, though, to see the x1900xt 512mb not doing any better than that. That card is my number one choice as soon as I have the budget for a new build. Are the games just developing faster than the graphics cards?
other way around. Cards are WAY ahead of game devs. It took years for devs to utilize many features in a 9700pro I had. Got it a bit after it came out and even a year ago games were finally taxing it hard.

My current 1900xt just flies through everything. Chews up every game I throw at it. That is why I am convinced there is an issue w/ that particular game... Hitman is a console port, and many of them suffer from performance issues on PC. (GTA:SA really stuttered on my old 9700pro even though it is far and above any specs for the ps2... Looked good, just that the code tends to do alot of useless work when ported badly)
 

Eurasianman

Distinguished
Jul 20, 2006
883
0
19,010
5
he has 3 slots for memory and has used all three of them right? i heard that if you fill the 3 slots you half the speed of the memory, at least i no this is true with old sdram.

am i right or was i just reading some bullsh*t?
um, my ASUS K8N-E Deluxe has 3 memory slots.
SLOT 1: Corsair XMS 1024 DDR400 @ 2-3-3-6
SLOT 2: Corsair XMS 512 DDR400 @ 2-3-3-6
SLOT 3: Corsair XMS 512 DDR400 @ 2-3-3-6

Sandra reports it running at the full 400 MHz as well as nVidia nTune software

I read what you were saying somewhere, but mine seems to run just fine! :D
 

fainis

Distinguished
Feb 10, 2006
763
0
18,980
0
Hi all

I was wondering if anyone here has any suggestions as to why i am getting poor performance with my new x1900xt 512 mb

please see the below screenshots in hitman blood money

On the initial welcome screen , not really much happening 20fps !



Here are all the settings i have set in the options menu .



An ingame screenshot again 20Fps the max i get is about 30fps .



i got 7667 points in 3dmark 2005 .

My Spec

Videocard: ATI X1900XT 512MB
Processor: AMD Athlon64 3200+ 130nm, Newcastle
Mainboard: GigaByte Nforce4 K8NE Socket 754
Memory: DDR 400 1500Mb ( 1 x 1gb 2 x 256mb )
Soundcard: Integrated Sound
PSU: Enermax 650W

I have made sure that the driver for the card is set to application preference for AA and AF .

I am running all the latest drivers for everything .

Any help would be appreciated , as its driving me nuts ..

Cheers
the way i see it:

first my sistem (intel630ht3gh2ML2/x850xt/1024dualddr2) runs like a beast in hitman 2... i guess i get a minimum 30 fps ..and a max 50 60 fps.....in 1280x1024 4xAA, 4xAF, all settings to the max.....

your x1900xt is the most powerfull component you have ...if there is anything that holds you is the rest of the sistem......the old 754 processor, no dual channel support,,,etc...
 

fainis

Distinguished
Feb 10, 2006
763
0
18,980
0
ohh..and one more thing my ..friend ..i think that your sistem will run faster with two 512 memory modules ..why..simply as that...is because of your mobo which is limited :

when you use one or two sticks ..you`ll have 400Mhz per same 750Mbps
if you use 3 slots you will have same 333Mhz or even less 266Mhz modules at same 500Mbps

you mobo will not support dual channel but imagine....the bandwith will increase considerably...from few hundreds Mhz to same 2Gbps or even higher and also higher Clocks....

good luck
 

banjax

Distinguished
Aug 24, 2006
5
0
18,510
0
hi guys , i headed off home at lunch time and tried a few of your suggestions

if you read my original post i had posted that i got 7667 points in 3dmark05 , so i went home took out the two 256mb dimms , double checked the driver ( which had somehow turned AA and AF back on ) and defragged the disks

low and behold i now get a score of 8900 . thats a big jump . I havent got a chance to try hitman yet , as by the time i had done all that i had to go back to work !!

Ill take another look tonight and post here . thanks for all the help guys really appreciate it ..
 

Heyyou27

Splendid
Jan 4, 2006
5,164
0
25,780
0
the way i see it:

first my sistem (intel630ht3gh2ML2/x850xt/1024dualddr2) runs like a beast in hitman 2... i guess i get a minimum 30 fps ..and a max 50 60 fps.....in 1280x1024 4xAA, 4xAF, all settings to the max.....

your x1900xt is the most powerfull component you have ...if there is anything that holds you is the rest of the sistem......the old 754 processor, no dual channel support,,,etc...
The screenshots he showed are of Hitman Blood Money, not Hitman 2; big difference.
 

sojrner

Distinguished
Feb 10, 2006
1,733
0
19,790
1
I would bet $ that if you put the sticks of ram back in it will still be fine. There is nothing wrong w/ the ram setup on that system. AA and AF being forced on in the driver will have a huge effect on any game, some more than others. Like I said, I am pretty sure it is all a software thing and not your hardware. That 8900 is a tad low for the card, but w/ the cpu and single channel ram (regardless of how much or configuration) that could be where it will stay.

Basically you were running AA and AF on everything on the system if you had it on in the drivers. That will affect any app you run, including 3dmark. Good to know you found it. (looks like it anyway. ;) )

rock on.
 

fainis

Distinguished
Feb 10, 2006
763
0
18,980
0
the way i see it:

first my sistem (intel630ht3gh2ML2/x850xt/1024dualddr2) runs like a beast in hitman 2... i guess i get a minimum 30 fps ..and a max 50 60 fps.....in 1280x1024 4xAA, 4xAF, all settings to the max.....

your x1900xt is the most powerfull component you have ...if there is anything that holds you is the rest of the sistem......the old 754 processor, no dual channel support,,,etc...
The screenshots he showed are of Hitman Blood Money, not Hitman 2; big difference.

yes ..man ..sorry ...did i say hitman 2 ..ahh yes ..sorry..of course it`s hitman blood and money...
 

The_OGS

Distinguished
Jul 18, 2006
646
0
19,010
13
Hi banjax,
I agree with the guys - your rig is just a little 'unbalanced'.
You have the very good vidcard but with only S754 mobo and XP3200+ @ 2000MHz.
I agree you will get best performance using just the single 1GB stick of memory, and tight latency timings.
I also recommend you do not run CCC all the time when your rig is started - ATI provides the 'Restart Runtime' if you ever wish to manually start it (to make adjustments, then reboot). I keep mine off, it is rarely needed!
Anyway, approaching ~9000 in 3DMark '05 is really a very good score :^)
My brand new rig has just produced the following:
3DMark 06 - 5649
3DMark 05 - 10985
3DMark 03 - 18388
You must soon step up your CPU/mobo (it is the platform that has produced the huge overall system speed improvements since ~2004). I have been building Back To School rigs using Athlon64 3800+ (2.4GHz, AM2) single-core - it's a joke, I can get them for ~$100 bucks and they are really very good.
But tune up the rig you have, optimize it to the max, and take your 9000 3DMarks & be happy. My old rig (XP3200+ Barton and X1600Pro) scored only 6691 in 3DMark '03!
You've got that well beat, heheh...
Regards
 

sojrner

Distinguished
Feb 10, 2006
1,733
0
19,790
1
Hi banjax,
I agree with the guys - your rig is just a little 'unbalanced'.
You have the very good vidcard but with only S754 mobo and XP3200+ @ 2000MHz.
I agree you will get best performance using just the single 1GB stick of memory, and tight latency timings.
I also recommend you do not run CCC all the time when your rig is started - ATI provides the 'Restart Runtime' if you ever wish to manually start it (to make adjustments, then reboot). I keep mine off, it is rarely needed!
Anyway, approaching ~9000 in 3DMark '05 is really a very good score :^)
My brand new rig has just produced the following:
3DMark 06 - 5649
3DMark 05 - 10985
3DMark 03 - 18388
You must soon step up your CPU/mobo (it is the platform that has produced the huge overall system speed improvements since ~2004). I have been building Back To School rigs using Athlon64 3800+ (2.4GHz, AM2) single-core - it's a joke, I can get them for ~$100 bucks and they are really very good.
But tune up the rig you have, optimize it to the max, and take your 9000 3DMarks & be happy. My old rig (XP3200+ Barton and X1600Pro) scored only 6691 in 3DMark '03!
You've got that well beat, heheh...
Regards
not an XP proc, not 2GHz... the OP already said it was 2.2GHz. b/c the 754 chips ran only single channel ram, they had a higher speed to offset the lower ram performance. (and still keep the same "rating" of 3200 or whatever) His is still a fine system, and getting 1000 more bungholio marks is not worth a whole system upgrade IMO if his games still run fine. (which now that he has AA and AF back to defaults should be the case)
 

badge

Illustrious
Jun 17, 2006
13,722
0
41,660
237
Surprised no one has suggested you install your video card in a different system and see if it performs like it should. Like many have suggested, it's likely your system's other components are responsible for the poor performance of an otherwise overwhelming video processor.
 

The_OGS

Distinguished
Jul 18, 2006
646
0
19,010
13
Yes, whatever (I can't get S754 Athlons anymore, so didn't have the exact info) but it is what it is...
His is still a fine system, and getting 1000 more bungholio marks is not worth a whole system upgrade IMO if his games still run fine.
I agree 100%. His performance is pretty good :^)
L8R
 

Similar threads