Question Bios

May 10, 2021
31
0
30
0
Hey I'm a new to the pc world. I've a Asrock B450 Steel Legend ATX motherboard. So I enabled XPM on my Corsair Vengeance RGB Pro 8GB 3200MHz. I've a Ryzen 3 3200G. Few days after enabling XMP, I went into the bios and suddenly the ram speed got back to 2133MHz. Btw the ram was smoothly running at 3200MHz before going to the bios. After that I again enabled XMP and so far no problem has occurred even if I go to the bios again. Was that incident something that I should worry about? Since I'm new, I am wondering if that behavior was normal or not.

Kinda same thing once again too, I disabled the led settings in the S5 mode. But it took me several reboots after disabling and enabling the setting and then finally getting the desired result. But things are now working fine. So is it all normal if these settings can sometimes be finicky? Do note that due to some power supply issues, I had to shut down my pc in the process quite a few times but only after saving and exiting from the bios. Thanks in advance.
 
Last edited:
Your RAM may be unstable in it's XMP during bootup and whenever it fails it just reverts to default JEDEC settings. You probably don't notice it as it works OK otherwise.

You might try setting the DRAM voltage manually. Check the package it came in, or other manual, it's usually 1.35V. That frequently helps.
 
Reactions: Iftekhar Ifty
May 10, 2021
31
0
30
0
Your RAM may be unstable in it's XMP during bootup and whenever it fails it just reverts to default JEDEC settings. You probably don't notice it as it works OK otherwise.

You might try setting the DRAM voltage manually. Check the package it came in, or other manual, it's usually 1.35V. That frequently helps.
The ram voltage is at 1.35V. But should I downclock the ram to 2933MHz? Since that's the official rating for the Ryzen 3 3200G. Or should I just keep it there and if that again happens I'll just enable the XMP again as it is working fine otherwise.
 
The ram voltage is at 1.35V. But should I downclock the ram to 2933MHz? Since that's the official rating for the Ryzen 3 3200G. Or should I just keep it there and if that again happens I'll just enable the XMP again as it is working fine otherwise.
Is it set manually to 1.35V by the DRAM voltage setting in BIOS though? That's what's important: use the manual setting, do not let the XMP setting alone do it. It seems as though the BIOS sets the XMP frequency before setting the voltage making it fail to train memory, but when it's set manually it will use that voltage all the way through. (That may not be completely right, it's just the way it seems to work on many motherboards)

Also make sure your DIMM's are in the right slots: the 2nd and 4th going away from the CPU.

If after setting it manually it still fails to boot with correct memory speed you can try manually downclocking to 2933. Leave it set in XMP, though, as that sets other needed timings.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS