Question blank screen after installing GPU

Page 2 - Seeking answers? Join the Tom's Hardware community: where nearly two million members share solutions and discuss the latest tech.
Apr 22, 2019
31
0
30
0
Na that motherboard has different socket 1150 for 4th/5th gen. You need 1155 socket motherboard, ie z77.

Search 3770k compatible motherboards.
hey i dont really find much, but do you think motherboard that use 1155 socket will be enough for GTX 750ti?
 

boju

Champion
That's up to you. Sorry I wouldn't know what's available to you second hand or how much. All i can give advice on is buy a board compatible with your cpu that is made by Asus, Asrock, Gigabyte or Msi.
 
Apr 22, 2019
31
0
30
0
That's up to you. Sorry I wouldn't know what's available to you second hand or how much. All i can give advice on is buy a board compatible with your cpu that is made by Asus, Asrock, Gigabyte or Msi.
ok, thank you so much for your help and everything.
 
Apr 22, 2019
31
0
30
0
That's up to you. Sorry I wouldn't know what's available to you second hand or how much. All i can give advice on is buy a board compatible with your cpu that is made by Asus, Asrock, Gigabyte or Msi.
but before that i was wondering if my gpu dint work/broken. but when i start the pc it show "american megantrends" logo and my brother said that if that logo pop up it mean none of my hardware are broken
 
Apr 22, 2019
31
0
30
0
If 750Ti gave an image at post then it's working.

If this is so then there's nothing wrong with your motherboard dude, the graphics card is probably at fault. Can you try another card?
yes i can. But when i turn on my pc there is no rig show up, never show up
 

boju

Champion
yes i can. But when i turn on my pc there is no rig show up, never show up
But you said you see "american megantrends" logo which is during post, what do you mean there is no rig show up?

Unless you mean no display after that then it certainly could be the video card. Try another.

If a video card was not compatible at all you would get nothing not even american megantrends logo.
 
Apr 22, 2019
31
0
30
0
Which 750Ti model do you have?

Most 750Ti's don't need an auxiliary 6 pin to power it, im wondering if yours could have and missed it?

i plug the 6 pin. Anyway i know why my screen went blank and show american megatrends for only a while, it because of my motherboard, i think my 750TI is not compatible with my motherboard and i checked gpu stuff in bios and there is nothing helpful and there is no option for external gpu... And btw i went to my cousin house just to check to my gpu is it dead or not and its not dead at all it can boot to windows10 right away, so iam sure i need to buy another motherboard
 

ASK THE COMMUNITY