Components, Hard Drive and SSD, recognized incorrectly by Device Manager and Speccy

haza12d

Prominent
Apr 17, 2017
90
0
660
6
I'm having issues with my newly built system. Device Manager and Speccy are reporting back the wrong information for two of my devices.

I have a 2TB 7200RPM Hitachi Mechanical Hard Drive showing up as a Crucial 960GB SSD and a 120GB mSATA SSD in a 2.5" Sabrent Enclosure/Adapter coming back as a 250GB Samsung 850 EVO.

All the components are brand new.

Specs:
i7 8700K
Corsair H115i Pro
MSI Z370 Gaming M5
16GB 4x4GB HyperX DDR4 2400
MSI GTX 1080 Gaming X 8G
Corsair HX1000i
Corsair Force MP500 120GB
Samsung 850 EVO 250GB SSD
Samsung 850 EVO 120GB mSATA
Hitachi 2TB 7200RPM HDD
Corsair 780T Full Tower
ASUS PCE-AC68 PCI-E Adapter

BIOS shows the correct information on Board Explorer and CrystalDisk Info also shows the correct information for the said components.

I believe I have the most up to date BIOS.

Any clues why the system is being all weird like this?
 

jimmysmitty

Champion
Moderator
Can you post a screenshot of this? It seems odd that Windows would misidentify them this way since it goes based on the hardware IDs that are specific to the vendor.

Also, which version of Windows are you running and was this a clean install?
 

palawan

Honorable
Feb 27, 2014
1
0
10,510
0
Same problem, two identical drives, one correctly identifies as
PNY CS900 240GB SSD
and the other as
PNY CS 90 0 240 GB SSD SCSI DISK DEVICE
with a space between the two zeros in 900.
I can't figure out how to attach a screen shot.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS