Computer Won't Boot With New Monitor [SOLVED]

Oct 12, 2018
3
0
10
0
Hello, I ran into an issue Ive never seen before. Hoping somebody can help. First some specs:

Windows 10
16gb RAM
GTX 970
i7-6700k

So I've been running a 4 monitor setup for the past 2 years. 1080p and not for gaming. Never any issue. I just got a new monitor BenQ SW271 (4k) to replace one of my existing ones. Had it for a few days, no issue at all.

Today when I went to reboot my computer, upon boot all screens were black and the computer kept beeping. After some troubleshooting (unplugging parts, trying to boot, etc) I discovered this only happens when the new monitor is connected. If I unplug it, boot up my computer with the 3 old monitors there is no problem. I can even then plug in the new one (after it's booted) and it works just fine. It's only on reboot I see an issue.

Any ideas?
Thanks!
 
Oct 12, 2018
3
0
10
0


Yes, and remembered that the old monitor was connected via DisplayPort to HDMI. I will share what info I learned for anybody else...

I started searching DP issues and apparently it's a common problem with DisplayPort connections. I guess most cables you get don't follow the standard and pin 20 provides power and is not supposed to. So the monitor is actually leaking power back to the graphics card/computer when it's off. I'm not 100% sure if that was the issue, but during my research of that and my new search terms I came across a DP driver update tool that did the trick.

https://www.nvidia.com/object/nv-uefi-update-x64.html
 
Oct 12, 2018
3
0
10
0


Thanks, I'm glad to. Also thanks for the reply.

To get the most out of this monitor I really needed it connected via DisplayPort. Connecting it with HDMI would be like buying a Ferrari and not going above 30MPH!

 

ASK THE COMMUNITY

TRENDING THREADS