Question Cpu light goes on then i hear a bang and lights flash...

May 17, 2023
1
0
10
k so i was just doing some work, using Chrome like normal when most things freeze and I can't open anything or load anything, first I thought it was the internet but file explorer didn't open so I just decided to restart, when I did the CPU light came on even after I unplugged everything (after looking at other threads), so I tried reseating the CPU, but I noticed that I bent an RGB header so I bent it back and plugged it in again. After I turned it back on I heard a bang/crack sound while all the lights on my PC flashed (looked like a power surge), that went on for abt 1 second before I turned the switch off, after which I could smell a faint burning smell (I have a bad sense of smell).



Ryzen 5 5600
Rtx 2060 zotac
Aorus B450 pro (v1 I think)
Crucial p2 250gb
MAG A650BN (650 watt psu)
Silverstone pf240w (rad)

the only USB devices I had were my mouse (glorious model o), my keyboard (redragon k552-rgb), and a random micro-usb cable that was (it wasn't at the time) connected to my Xbox controller. I might be able to get (some parts: CPU, ram, PSU, and motherboard) under warranty not sure.

Any help would be very appreciated
 
Last edited:

DaleH

Prominent
Mar 24, 2023
478
49
720
k so i was just doing some work, using Chrome like normal when most things freeze and I can't open anything or load anything, first I thought it was the internet but file explorer didn't open so I just decided to restart, when I did the CPU light came on even after I unplugged everything (after looking at other threads), so I tried reseating the CPU, but I noticed that I bent an RGB header so I bent it back and plugged it in again. After I turned it back on I heard a bang/crack sound while all the lights on my PC flashed (looked like a power surge), that went on for abt 1 second before I turned the switch off, after which I could smell a faint burning smell (I have a bad sense of smell).



Ryzen 5 5600
Rtx 2060 zotac
Aorus B450 pro (v1 I think)
Crucial p2 250gb
MAG A650BN (650 watt psu)
Silverstone pf240w (rad)

the only USB devices I had were my mouse (glorious model o), my keyboard (redragon k552-rgb), and a random micro-usb cable that was (it wasn't at the time) connected to my Xbox controller. I might be able to get (some parts: CPU, ram, PSU, and motherboard) under warranty not sure.

Any help would be very appreciated
The most likely cause is the PSU. The sound would have been from capacitors that exploded.