Question Disabling CSM & Enabling Safeboot causes me to boot into BIOS

Aug 5, 2022
3
0
10
0
I tried to disable CSM to enable Safeboot so I can play Valorant but when I do so and save and exit my BIOS it boots right back up into BIOS. I re-enabled CSM and disable safeboot and it boots into Windows. Im not sure why this keeps happening, I just want to enable safeboot

GTX 1050-Ti
i3 8100
h310m a-cf
8x4gb ram
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
58,302
4,737
161,190
10,354
Its because your hard drive is formatted as MBR and it doesn't work if you disable CSM

Can you right click start
choose disk management
when next window opens, open it so it shows all details of upper and lower area
take a screenshot, upload to an image sharing webiste and show link here

We can convert drive to GPT so you can use Secure boot but we need to look at that first.
 
Aug 5, 2022
3
0
10
0
Its because your hard drive is formatted as MBR and it doesn't work if you disable CSM

Can you right click start
choose disk management
when next window opens, open it so it shows all details of upper and lower area
take a screenshot, upload to an image sharing webiste and show link here

We can convert drive to GPT so you can use Secure boot but we need to look at that first.
Thank you for responding so quickly, I think this is what you meant?
View: https://imgur.com/MCfrNPK
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
58,302
4,737
161,190
10,354
Last message should be "Boot files created successfully".


diskpart
list disk
select disk 1

(select 250GB OS drive)
list partition
select partition 2

(select 511MB partition, we're going to delete it to make space for new bootloader)
delete partition override
create partition primary
format fs=ntfs quick
active
assign letter=H
exit
bcdboot C:\windows /s H:


After this is done, boot into BIOS and change boot priority (HDD BBS settings), so 250GB drive is first in boot order.
Check Disk Management. "System, Active" partition now should be on 250GB drive.

then follow this: https://it-infrastructure.solutions/how-to-switch-from-legacy-to-uefi-boot-mode-mbr2gpt-convertion/
 
Last edited:
Aug 5, 2022
3
0
10
0
If UEFI is supported, then execute following from elevated command prompt.
Regular command will give error on last step.
If you get any errors then stop immediately.
Last message should be "Boot files created successfully".


diskpart
list disk
select disk 1

(select 250GB OS drive)
list partition
select partition 2

(select 511MB partition, we're going to delete it to make space for new bootloader)
delete partition override
create partition primary
format fs=ntfs quick
active
assign letter=H
exit
bcdboot C:\windows /s H:


After this is done, boot into BIOS and change boot priority (HDD BBS settings), so 250GB drive is first in boot order.
Check Disk Management. "System, Active" partition now should be on 250GB drive.

then follow this: https://it-infrastructure.solutions/how-to-switch-from-legacy-to-uefi-boot-mode-mbr2gpt-convertion/
Hey I'm going to convert legacy to UEFI mbr2gpt thing tomorrow, but after I do convert it would I be able to enable safeboot?
 

ASK THE COMMUNITY