Do I need a larger power supply? Strange USB issues.....

Jan 27, 2019
7
0
10
First off my PC specs are
i7 8700k OC to 4.7
ASUS Z370-P motherboard
MSI 1080ti OC edition
16gb DDR4
240gb SSD
1TB HD
Noctua NH-U12S Fan/Cooler
Themaltake 600watt Smart series power supply.

I noticed after OCing my 8700k some strange behavior with my mouse and keyboard. They would intermittently freeze while everything else was working in the background. Also when in the BIOS menu, the mouse was unusable, even before overclocking. I had to do all BIOS changes with the keyboard. Mouse pointer would freeze for about 5-10 secs after moving it when trying to navigate in the ASUS Bios.

My mouse and keyboard are wireless and I thought it was due to it being a cheap $20 Amazon set. I purchased a Logitech combo and the same thing was happening.

Plugged into the PC on the USB 3.0 ports are my Oculus Rift, my Fanatec Steering wheel (off at the time) Rift sensor and wireless adapter for keyboard/mouse.

I noticed today, when I unplugged the USB for the Oculus headset, my mouse worked smooth and flawless. When in the BIOS is worked perfect(where as before it was unusable). When I plug it back in, the mouse gets glitchy and slow in the BIOS and it freezes up in windows intermittently.

It seems like something is going on with the USB ports? Is it possible my power supply is the cause of this or something else? I have tried switching between different USB 3.0 ports and it still happens. Everything is plugged directly into the PC, there is no USB adapter/splitter adapter.
 
Jan 27, 2019
7
0
10


Thanks for the suggestion. I tried the software. It seemed to work temporarily but my issue still comes and goes intermittently. It definitely helped clean up some of the USB connection mess. I think I narrowed it down to a bandwidth issue with my USB controller. I think maybe due to the cheap motherboard. What I noticed was. If I go to Oculus Home software and look at my connected devices (headset and sensor) They are plugged into 3.0 plugs, but sometimes they will say USB 2.0 instead. Its intermittent though, sometimes on a reboot, 1 may be 3.0, both may show 2.0. I did some searching and it looks like its a common problem when Oculus detects a slower connection it switches to 2.0. Which also explains why I have intermittent stutters when in VR.

I have ordered a powered USB PCIe card and will give that a shot instead of running everything off the mobo. Hopefully this solves the issue.
 

ASK THE COMMUNITY

TRENDING THREADS