Question Does Legacy+UEFI mean actual UEFI support?

Kusky

Distinguished
Nov 3, 2013
67
0
18,640
1
In my MSI bios I have the option for Legacy+UEFI or UEFI. I can't select UEFI as my drives are not currently formatted correctly for it. However when I select Legacy+UEFI it still says my BIOS mode is legacy in system info, plus I have no UEFI options in advanced restart. So if I converted my drives from MBR to GBT would windows still function as its Legacy+UEFI? Or would I still need to change to UEFI after.

Edit - Tried to move to systems category but saw no delete option and didn't want to spam.
 
In my MSI bios I have the option for Legacy+UEFI or UEFI. I can't select UEFI as my drives are not currently formatted correctly for it. However when I select Legacy+UEFI it still says my BIOS mode is legacy in system info, plus I have no UEFI options in advanced restart. So if I converted my drives from MBR to GBT would windows still function as its Legacy+UEFI? Or would I still need to change to UEFI after.

Edit - Tried to move to systems category but saw no delete option and didn't want to spam.
Legacy+UEFI = Auto so windows would BOOT in either mode. If your Windows were installed in Legacy/CSM mode than they would BOOT and work in Legacy BIOS mode. For UEFI mode disk has to be GPT which is easy to convert from MBR. Look in Disk Management if there is EFI partition
.https://www.easeus.com/partition-master/convert-mbr-disk-to-gpt-disk.html
 
In my MSI bios I have the option for Legacy+UEFI or UEFI. I can't select UEFI as my drives are not currently formatted correctly for it. However when I select Legacy+UEFI it still says my BIOS mode is legacy in system info, plus I have no UEFI options in advanced restart. So if I converted my drives from MBR to GBT would windows still function as its Legacy+UEFI? Or would I still need to change to UEFI after.
System Info shows mode, in which windows is installed in.
If your windows is installed in legacy mode, then system info will show BIOS mode legacy.
You can't change it by altering BIOS options.

You'd have to convert your windows installation to UEFI.
This can be done with mbr2gpt utility.
Only after this conversion you could change BIOS to UEFI only.

There are requirements for mbr2gpt to function properly though.
Please show a screenshot from Disk Management.
(upload to imgur.com and post link)
 

Kusky

Distinguished
Nov 3, 2013
67
0
18,640
1
System Info shows mode, in which windows is installed in.
If your windows is installed in legacy mode, then system info will show BIOS mode legacy.
You can't change it by altering BIOS options.

You'd have to convert your windows installation to UEFI.
This can be done with mbr2gpt utility.
Only after this conversion you could change BIOS to UEFI only.

There are requirements for mbr2gpt to function properly though.
Please show a screenshot from Disk Management.
(upload to imgur.com and post link)
View: https://imgur.com/a/Alh5L4L


My issue with converting MBR to GPT though is that my system and boot somehow ended up on different drives, so it recommends I don't try to convert otherwise I may fail to boot. You can see system is on my HDD and boot is on my C drive, an SSD.
 
My issue with converting MBR to GPT though is that my system and boot somehow ended up on different drives, so it recommends I don't try to convert otherwise I may fail to boot. You can see system is on my HDD and boot is on my C drive, an SSD.
For mbr2gpt to functionproperly, bootloader has to be located on same physical disk, where windows is.
Currently bootloader is on 2TB drive (549MB System,Active partition).
1st you need to create bootloader on OS disk.
Execute following from elevated command prompt. Regular command prompt will give error on last step.
If you get any errors, then stop immediately.
diskpart
list disk
select disk 2
list partition
select partition 2
(select 523MB recovery partition)​
delete partition override
create partition primary
format fs=ntfs quick
active
assign letter=H
exit
bcdboot C:\windows /s H:

Last message should be "Boot files created successfully".

If all went well, then next - reboot into BIOS and change boot priority
so 250GB drive is first in boot order.
Boot into windows and show screenshot from Disk Management.
Small 523MB partition on 250GB drive should have "System, Active" in description now.

After that you can use mbr2gpt to convert OS drive to GPT.
 

Kusky

Distinguished
Nov 3, 2013
67
0
18,640
1
For mbr2gpt to functionproperly, bootloader has to be located on same physical disk, where windows is.
Currently bootloader is on 2TB drive (549MB System,Active partition).
1st you need to create bootloader on OS disk.
Execute following from elevated command prompt. Regular command prompt will give error on last step.
If you get any errors, then stop immediately.
diskpart
list disk
select disk 2
list partition
select partition 2
(select 523MB recovery partition)​
delete partition override
create partition primary
format fs=ntfs quick
active
assign letter=H
exit
bcdboot C:\windows /s H:

Last message should be "Boot files created successfully".

If all went well, then next - reboot into BIOS and change boot priority
so 250GB drive is first in boot order.
Boot into windows and show screenshot from Disk Management.
Small 523MB partition on 250GB drive should have "System, Active" in description now.

After that you can use mbr2gpt to convert OS drive to GPT.
I did all you said and I got a "Boot files created successfully". I then put the 250gb drive to first in boot order in BIOS. Rebooted and checked Disk manager. The small recovery partition changed to "primary partition", but the system remains on the HDD disk 0.

View: https://imgur.com/n4Z3lKf
 

Kusky

Distinguished
Nov 3, 2013
67
0
18,640
1
Disable other boot options.
Leave only 970 evo 250GB - in the list.
I left only the 970 evo 250gb active and I got the message “Reboot and Select proper boot device or insert boot media in selected boot device”. I tried pressing f11 for boot menu to make sure the right drive was enabled and it was which returned the same message.
 

ASK THE COMMUNITY