Question DualShock4 controller not working (Code10,Code43)

May 14, 2019
2
0
10
0
Hello there,
First and foremost, other USB devices (Arcade Stick, Mouse, Keyboard, external HDD's) are working fine on my Windows Install, so it shouldn't be a USB port problem. The DS4 controller in question is also operative, and gets detected by Windows and Steam on my Windows 7 install on my laptop (usable too). On my main PC however (Windows 8.1), it's a completely different thing. I had been using a DS4 controller before on my Win8.1 install, and there were no problems at all connecting it to my PC, and then letting Steam detect and configure it. The new DS4 pad however is giving me some really strange driver problems:

Sometimes Windows can not start certain device functions of the controller, sometimes I can't get it even recognized by Windows (Code 43), and on rare occasions, Windows actually detects it and the lightpad of the DS4 pad is flashing yellow (Steam however does not detect it, and DS4Windows only detects it for one second, but then the controller entry disappears again).

I also tried out a lot of these "solutions" that can be found on the internet (push little button close to the R2, uninstalling the HDMI-compilant game controller entry in the Windows Device Manager, and reconnect DS4 with MiniUSB, completely reinstalling Steam, because it comes with drivers as well), but none of them worked either. The only/final thing that comes up to my mind is this:

"Could there maybe be some old "driver" entries (from the time when I connected my first DS4 controller to my 8.1 install years ago) in my registry that are somehow acting up, thus making the controller install almost impossible?"
Because, like I said, when I tried to connect the new DS4 pad to my laptop (which was "controller-free" up until this point), it had no problems at all identifying and installing it (giving me these little messages with the green check marks).

Question is, where could I find those registry entries, and what needs to be deleted, or reset?

I am really at wits end here, because this is a really really weird problem.

Help would be very much appreciated,
Vlan
 

ASK THE COMMUNITY

TRENDING THREADS