[SOLVED] Ethernet keeps disconnecting only when playing games (after countless tries to fix it)

Nira99

Prominent
Mar 10, 2019
7
0
510
0
Hello,

I know there must be countless threads with the same title out on the internet but I ask you nicely to take a look at mine too, because I have tried so many things already(and read so many similar threads) that I don't know where the problem could lay.

My internet connection:
https://www.speedtest.net/result/8102070228

My setup:
OS: Windows 7 Ultimate (64-bit)
Intel Core i5 6400 @2.70
MSI MS-7996
NVIDIA GeForce GTX 950
16 GB RAM
NET CARD: Intel® Gigabit CT Desktop Adapter
Ethernet cable

So far I've tried a lot of options
Since this has been going on ever since december 2018, I cant remember quite the order I did them(tries to fix the issue), but for surely I reinstalled windows and bought a new router and the problem kept persisting.

I did the following settings
  • Speed & Duplex set on 1gb.
  • Unchecked the power management options
  • Set the power savings to High Performance
  • Reinstalled drivers
  • Updated drivers
This was with my prior net card.After buying the one listed above, which brought me relief for a few weeks, the disconnections appeared again.

Settings to my current NIC:
  • Speed & Duplex set on 1gb.
  • Unchecked the power managment options
  • Set the power savings to High Performance
  • Updated Driver
  • Receive Buffers: 2048
  • Priority and VLAN - Enabled
  • Receive Side Scalling - Enabled
I have also checked my new router for firmware updates and it is currently up to date.

I've actually came across one of the threads on here which made me buy a new nic and I had finally thought that my old nic was the issue after all, turns out the problem keeps on and I have no idea what else I can try out.

It's my first time I'm ever encountering such long term issues with my ethernet and It makes me really unmotivated to try fix it myself as nothing worked. A reminder once again that the ethernet disconnects ONLY when playing games.
Thank you for your time to read this, I hope some of you might be able to lend me a hand with it.
 
Last edited:
The most likely cause is your connection from your house to the ISP is losing data. Games have more issue than other application.

First run a constant ping to your router in a background window while you run the game. If you get loss here or large spikes in the latency you have a problem with the equipment inside your house.

If that is ok next do the same to a IP like 8.8.8.8. This is to see if it is your internet or only the game that is having issues. If you have a actual network issue both the game and the ping should show problems at the same time.

You could at this point call the ISP and see if they will fix it since you can prove it is outside your house. They may try to say it is the server...ie both the game server and the 8.8.8.8 (google dns server) and then you must do more ping tests but maybe you get lucky and you get a tech that is not a idiot.

If all the pings show no issues you likely have a issue with the games or some issue with the game company ISP. These type will be much harder to get fixed.
 

shknawe

Respectable
Oct 22, 2016
1,288
47
2,490
140
Do you get any messages when it disconnects, or windows log entries? Do you use antivirus program during gaming? Does it happen with online gaming, or single player gaming?
 

Nira99

Prominent
Mar 10, 2019
7
0
510
0
Do you get any messages when it disconnects, or windows log entries? Do you use antivirus program during gaming? Does it happen with online gaming, or single player gaming?
From the game its the usual system message: Connection to server lost(i think).
windows log entries? like a window pop up? cuz no
Also my internet logo(i guess) yknow the one from the bottom right on screen,isn't displaying the "!" sign when the wifi disconnects

No I do not use antivirus programs during gaming.
It happens with multiplayer gaming
 

shknawe

Respectable
Oct 22, 2016
1,288
47
2,490
140
From the game its the usual system message: Connection to server lost(i think).
windows log entries? like a window pop up? cuz no
Also my internet logo(i guess) yknow the one from the bottom right on screen,isn't displaying the "!" sign when the wifi disconnects
Ok so are you using a ethernet cable to your computer or are you using wifi?
 
The most likely cause is your connection from your house to the ISP is losing data. Games have more issue than other application.

First run a constant ping to your router in a background window while you run the game. If you get loss here or large spikes in the latency you have a problem with the equipment inside your house.

If that is ok next do the same to a IP like 8.8.8.8. This is to see if it is your internet or only the game that is having issues. If you have a actual network issue both the game and the ping should show problems at the same time.

You could at this point call the ISP and see if they will fix it since you can prove it is outside your house. They may try to say it is the server...ie both the game server and the 8.8.8.8 (google dns server) and then you must do more ping tests but maybe you get lucky and you get a tech that is not a idiot.

If all the pings show no issues you likely have a issue with the games or some issue with the game company ISP. These type will be much harder to get fixed.
 

Nira99

Prominent
Mar 10, 2019
7
0
510
0
[/QUOTE]
The most likely cause is your connection from your house to the ISP is losing data. Games have more issue than other application.

First run a constant ping to your router in a background window while you run the game. If you get loss here or large spikes in the latency you have a problem with the equipment inside your house.

If that is ok next do the same to a IP like 8.8.8.8. This is to see if it is your internet or only the game that is having issues. If you have a actual network issue both the game and the ping should show problems at the same time.

You could at this point call the ISP and see if they will fix it since you can prove it is outside your house. They may try to say it is the server...ie both the game server and the 8.8.8.8 (google dns server) and then you must do more ping tests but maybe you get lucky and you get a tech that is not a idiot.

If all the pings show no issues you likely have a issue with the games or some issue with the game company ISP. These type will be much harder to get fixed.
I will update you as soon as I can with the results that I will get from the commands you suggested, although it seems that during the week my wifi isn't crashing as often as it does on weekends so it might take a bit until i can get them running in the background whilst I experience a disconnection during gaming.
 

ASK THE COMMUNITY

TRENDING THREADS