Question Frequent stuttering/poor rendering/texture pop ins on multiple rigs?

Nov 17, 2021
2
0
10
0
Hey all, first I really don't know where to begin but this problem started about 9 months ago spanning from a cyberpowerpc, fast forward to present day I have gotten three differently spec pcs from Microcenter (G510, G707, G438) and all suffer from stuttering in frametime graph, I notice if I stand far away from a building it looks poorly rendered. Upon moving 5 feet away the building then renders in but I get frequent popping (see pictures below) honestly I don't even know where to begin or what to think anymore. I do know my electrical is pretty shoddy but I just got the main box replaced so I'm not sure if I'm facing a hardware problem or not (I really don't think it is considering it's the same problem across 6 different builds)

temps seem fine, GPU doesn't go over 60c and cpu is about 55-59c. If I may ask what are the most common reasons for stuttering/rendering issues? Could it be the fact it's daisy chained? (1 cable two splitter ends?) sorry if I said that wrong still learning pc talk lol.




Full specs:
MSI Z490-A Pro
MSI 3070 Gaming X Trio(Daisy chained, one cable two ends)
I7 10700k (ML240L cooler)
Neo Forza 2x16gb 2400mhz (xmp 3200mhz)
Powerspec 750W 80+ bronze (this will be replaced in the future)
Lian Li II case



Edit: Was testing out Mordhau a bit just now, turned off any signs of OC I could find (xmp off, intel oc off) but I noticed this weird rendering issue when going into settings and back into game. (The left picture looks as it should, a nice clear image of the wooden fence, the right is the artifacting pic)
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS