[SOLVED] G-sync active but not running in a specific game.

JerrWolf

Honorable
Dec 18, 2014
425
3
10,795
2
Hello and good evening everyone,
Quick question regarding G-sync.

So I've had this monitor for years, Dell S2417DG (1440p Gsync) and I have G-sync enabled, it's in the 3D settings as G-sync and not off or V-sync etc.
I've just assumed "It's on so it must be working, I just have terrible eye-sight" whenever I notice the FPS and smoothness acting up.
But today in FFXIV I have noticed it and decided to check my settings in case it was turned off.

  1. Game is running in fullscreen
  2. G-sync setting is in fullscreen
  3. I've tried windowed mode for the game and setting both.
  4. In the Control Panel 3d settings it is set to G-sync for all programs. I also enabled the G-sync Indicator.
  5. In the G-sync pendulum demo I ran the test and the indication shows up in the corner of my screen.
  6. I opened up a second game (Guild Wars 2) and the indicator also appears.
  7. in FFXIV the indicator does not appear; in Fullscreen or borderless/windowed.
Is there more testing to do to see if it's actually working or not?

A friend suggested using RTSS (Rivatuner Statistic Server) but I have no knowledge of that software.

Edit: For the record, if it matters--my FPS will go between 40-140FPS because it's an MMO and my PC is not the best.

CPU - i7 4790k no OC only Turbo
GPU - 980ti no OC only default settings.
RAM - DDR3 1333hz
 
Last edited:
Make sure the game profile in the NVIDIA Control Panel isn't overriding the default Gsync setting. (I doubt it, but check anyway).

Aside from that, I recommend setting a global FPS limit to a few FPS below your maximum refresh rate. Gsync (or any other VRR tech) gets wonky as you approach the maximum refresh rate, and if you go over you fall back to normal Vsync behavior (which is undesirable).
 

JerrWolf

Honorable
Dec 18, 2014
425
3
10,795
2
Is V-Sync off on 'Manage 3D settings'?
If you are getting fps over the refresh rate of the monitor gsync shuts off
The Vertical Sync is set to "Use the 3D application setting" I'll try turning it off and see if that changes anything.

I don't think my PC can really get 144hz, not all the time.
But I'll really notice when the FPS is around 70-90 instead of higher.
 
Make sure the game profile in the NVIDIA Control Panel isn't overriding the default Gsync setting. (I doubt it, but check anyway).

Aside from that, I recommend setting a global FPS limit to a few FPS below your maximum refresh rate. Gsync (or any other VRR tech) gets wonky as you approach the maximum refresh rate, and if you go over you fall back to normal Vsync behavior (which is undesirable).
 

JerrWolf

Honorable
Dec 18, 2014
425
3
10,795
2
Is V-Sync off on 'Manage 3D settings'?
Make sure the game profile in the NVIDIA Control Panel isn't overriding the default Gsync setting. (I doubt it, but check anyway).

Aside from that, I recommend setting a global FPS limit to a few FPS below your maximum refresh rate. Gsync (or any other VRR tech) gets wonky as you approach the maximum refresh rate, and if you go over you fall back to normal Vsync behavior (which is undesirable).
I think this might have been the issue here.
I turned off Vysnc and then yesterday the Gsync indicator did show up finally.
I also was told that the games in-game Fps limiter wasn't the best and had issues with G-sync or something like that. So I turned it off and added one to RTSS. Seemed to also help.

Thank you everyone for the info and quick solution!
 

ASK THE COMMUNITY