Question GeForce GTX 1050ti suddenly not displaying

Nov 15, 2019
4
0
10
0
Hi guys, I wonder if anyone can help me.

Earlier today I went to install a new second hard drive in my tower, noticed averything was looking rather dusty and proceeded to clean it. I didn't touch the GPU at all, the only thing that got touched/disconeccted was the old hard drive and the cpu cooling fan.

Upon putting everything back together and turning on, my monitor refused to display anything, and after hooking up another monitor and double checking with new cables and such I connected my monitor straight to the MB and voila, display!

Once I had everything started up I opened the device manager (I run windows 10 btw), located my gpu and under device status it gives the "Windows has stopped this device because it has reported problems. (Code 43)".

I've read a couple articles, done all available driver updates, tried the disable/enable then turn pc off and on and uninstall device, and none have worked.

Just for reference, the gpu is getting powered I assume as lights are on.

What else can I try? I'm getting some serious gaming urhes!
 
Nov 15, 2019
4
0
10
0
full system spec?
Running Windows 10 Home 64bit V. 1909

Processor is AMD A10-5800K, motherboard is Gigabyte F2A88X-D3H, 8 GB DDR3 RAM, 1tb standard HDD, 500w Nox Urano SX power supply, unsure of cpu cooler model as bought this pc second hand.

Have tried doing a full system restore this evening as advised by tech support at NVidia and nothing, really don't have the time to be waiting 40minutes again to get someone again though.
 
Nov 15, 2019
4
0
10
0
I'm really aware that it's a tacky build with a half decent card thrown in, but I really don't have the funds to throw at a new PC and it's worked for atleast the last 2 years with no problems.
 

ASK THE COMMUNITY

TRENDING THREADS